[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] PCI passthrough of 40G ethernet interface (Openstack/KV

From: jacob jacob
Subject: Re: [Qemu-devel] PCI passthrough of 40G ethernet interface (Openstack/KVM)
Date: Thu, 19 Mar 2015 19:37:47 -0400

On Thu, Mar 19, 2015 at 5:53 PM, jacob jacob <address@hidden> wrote:
> On Thu, Mar 19, 2015 at 5:42 PM, Shannon Nelson
> <address@hidden> wrote:
>> On Thu, Mar 19, 2015 at 2:04 PM, jacob jacob <address@hidden> wrote:
>>> I have updated to latest firmware and still no luck.
>> [...]
>>> [   61.554132] i40e 0000:00:06.0 eth2: the driver failed to link
>>> because an unqualified module was detected.     <<<<<<<<<<<<<<<<<<<<
>>> [   61.555331] IPv6: ADDRCONF(NETDEV_UP): eth2: link is not ready
>> So I assume you're getting traffic on the other port and it doesn't
>> complain about "unqualified module"?  Does the problem move if you
>> swap the cables?  The usual problem here is a QSFP connector that
>> isn't compatible with the NIC.  I don't have a pointer handy to the
>> official list, but you should be able to get that from your NIC
>> supplier.
> No. That is not the case.
> The traffic counters are for the dpdk test run which uses igb_uio driver.
> As i mentioned earlier, have tried all combinations of cable, pci slot
> , card etc to isolate any hw issues.

Everything works fine on the host and hence the
modules are verified to be working.
The issue is seen only when the device is passed through to a VM
running on the same host.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]