[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [Bug 1404278] Re: tap connections not working on window

From: Stefan Hajnoczi
Subject: Re: [Qemu-devel] [Bug 1404278] Re: tap connections not working on windows host
Date: Tue, 24 Mar 2015 11:10:06 +0000
User-agent: Mutt/1.5.23 (2014-03-12)

On Wed, Jan 07, 2015 at 04:09:55PM -0000, timsoft wrote:
> I have tried what you suggested (breaking the bridge on the host, and giving 
> the host tap and the guest eth0
> and tried pinging one from the other. I get 100% packet loss.
> This points to QEMU's tap networking as far as I can see.
> I have tried uninstalling the 64 bit version and installing the 32bit tap 
> adapter (and bridging it) from openvpn 2.3.6-I601  but that didn't seem to 
> make any difference.

You could put a fprintf(stderr, "Receiving a packet\n") into
net/tap-win32.c:tap_win32_send() as well as fprintf(stderr, "Sending a
packet\n") into tap_win32_write() if you think QEMU's Windows tap code
is broken.


Attachment: pgpUnxrFnb5jQ.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]