[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Help with deadlock when using sound

From: Programmingkid
Subject: Re: [Qemu-devel] Help with deadlock when using sound
Date: Wed, 6 May 2015 17:41:49 -0400

On May 6, 2015, at 5:31 PM, Peter Maydell wrote:

> On 6 May 2015 at 22:19, Programmingkid <address@hidden> wrote:
>> On May 6, 2015, at 5:10 PM, Peter Maydell wrote:
>>>> Thread 8 (process 29237):
>>>> #0  tb_jmp_cache_hash_func (pc=1) at exec/exec-all.h:208
>>>> #1  0x000000010000c9d7 in tb_find_slow (env=0x103846620, pc=133133655, 
>>>> cs_base=133118944, flags=244) at 
>>>> /Users/user/Documents/Development/Projects/Qemu/qemu-git/cpu-exec.c:309
>>>> #2  0x000000010000cae3 in tb_find_fast (env=0x103846620) at 
>>>> /Users/user/Documents/Development/Projects/Qemu/qemu-git/cpu-exec.c:327
>>>> #3  0x000000010000cf66 in cpu_x86_exec (env=0x103846620) at 
>>>> /Users/user/Documents/Development/Projects/Qemu/qemu-git/cpu-exec.c:485
>>>> #4  0x000000010003978b in tcg_cpu_exec (env=0x103846620) at 
>>>> /Users/user/Documents/Development/Projects/Qemu/qemu-git/cpus.c:1354
>>>> #5  0x0000000100039878 in tcg_exec_all () at 
>>>> /Users/user/Documents/Development/Projects/Qemu/qemu-git/cpus.c:1387
>>>> #6  0x0000000100038dec in qemu_tcg_cpu_thread_fn (arg=0x10383e400) at 
>>>> /Users/user/Documents/Development/Projects/Qemu/qemu-git/cpus.c:1032
>>>> #7  0x00007fff8251bfd6 in _pthread_start ()
>>>> #8  0x00007fff8251be89 in thread_start ()
>>> This backtrace says QEMU hasn't hung -- it is still executing
>>> guest code (though possibly the guest has crashed or gone off
>>> into the weeds, of course).
>> If it were still executing guest code, then accessing the monitor
>> would still work.
> Well, that backtrace says we're executing code. We're not stuck
> waiting for a lock, we're in the middle of the execution loop
> (looking for a TB for PC=0x7ef7557). Your command line hasn't
> redirected the monitor to the terminal or to a TCP port, so
> possibly it's just that the GUI has got wedged? Try with
> '-monitor stdio' and see if that's responsive.
Tried this, still froze.

> I just tried on OSX and for me there's no hang -- the BIOS
> boots normally, fails to find a valid image on the cdrom
> and drops into attempting to network-boot, same behaviour
> with or without -soundhw pcspk. (I build with coreaudio.)
> -- PMM

I did what you did "qemu-system-i386 -soundhw pcspk" and QEMU froze on me with 
this as the last thing printed on the screen: "Press Ctrl-B for the iPXE 
command line...". What version of Mac OS X are you trying QEMU on?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]