[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [Bug 1455912] Re: vnc websocket option not properly parsed

From: flrichar
Subject: [Qemu-devel] [Bug 1455912] Re: vnc websocket option not properly parsed when running on commandline
Date: Sun, 17 May 2015 14:08:03 -0000

I have more information about the bug.  The host I'm running this on is
called "tor' (no, it has nothing to do with an onion router, its an old
nickname and something I've been calling my main dev host for years).
Its IP is  If I designate the command line option  as "-vnc
tor:11,websocket=5711" or "-vnc,websocket=5711" it appears
to work fine.

I have to include the specific IP I wish it to listen on because this
host has a lot of different interfaces, and I don't want it listening on
all interfaces.  So there's still an issue with it resolving the "short"
name in local dns to the local IP, and listening only on that IP with
the abbreviated option.  It's still not parsed correctly.

On another host, with much fewer interfaces and addresses, a simple
"-vnc :80,websocket" works fine without modification.   Same version of
Qemu, the ArchLinux x86_64 package for 2.3.0-2.

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  vnc websocket option not properly parsed when running on commandline

Status in QEMU:

Bug description:
  All of my vms are started with a simple script on the command line.  
  Starting with Qemu 2.3.0, the option "-vnc host:port,websocket" is no longer 

  Previously if I said listen on Tor:17,websocket it would function
  correctly.  Now it's kicking an error:

  qemu-system-x86_64: -vnc tor:17,websocket: Failed to start VNC server on 
`(null)': address resolution failed for tor:on: Servname not supported for 

  The error leads me to believe it's not parsing the command line
  options for the "vnc" option correctly.  If I leave off ",websocket"
  it works correctly.  I've even tried, replacing the hostname with an
  IP address, and using the alternate form " -display
  vnc=tor:17,webscoket". It reports the same error.

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]