qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 07/12] qapi: qapi for audio backends


From: Kővágó Zoltán
Subject: Re: [Qemu-devel] [PATCH 07/12] qapi: qapi for audio backends
Date: Sat, 13 Jun 2015 00:59:35 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.7.0

2015-06-13 00:11 keltezéssel, Eric Blake írta:
+##
+# @AudiodevAlsaOptions
+#
+# Options of the alsa audio backend.
+#
+# @in: #optional options of the capture stream
+#
+# @out: #optional options of the playback stream

Marked optional here...

+#
+# @threshold: #optional set the threshold (in frames) when playback starts
+#
+# Since: 2.4
+##
+{ 'struct': 'AudiodevAlsaOptions',
+  'data': {
+    'in':         'AudiodevAlsaPerDirectionOptions',
+    'out':        'AudiodevAlsaPerDirectionOptions',

...but not here.

Oups. The code is the correct (they are not optional), I forgot updating the documentation. (Same goes for the other mismatches).


+    '*threshold': 'int' } }
+
+##
+# @AudiodevDsoundOptions
+#
+# Options of the dsound audio backend.
+#
+# @latency-millis: #optional add extra latency to playback
+#
+# Since: 2.4
+##
+{ 'struct': 'AudiodevDsoundOptions',
+  'data': {
+    '*latency-millis': 'int' } }

Style question - should we just call this 'latency', and document the
milliseconds unit in the description? But having the name latency_millis
in C code might not be all that bad, so you may not want to change this one.

There is also a buffer-usecs, so I vote for keeping latency-millis. Also there is timer-period in Audiodev. Maybe it should be renamed to timer-period-hz, to keep consistency. Or maybe change all of them to usecs.


Other issues acked.

Thanks,
Zoltan




reply via email to

[Prev in Thread] Current Thread [Next in Thread]