qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v2 1/2] xen_platform: switch to realize


From: Stefano Stabellini
Subject: Re: [Qemu-devel] [PATCH v2 1/2] xen_platform: switch to realize
Date: Mon, 26 Oct 2015 11:24:48 +0000
User-agent: Alpine 2.02 (DEB 1266 2009-07-14)

On Wed, 21 Oct 2015, Eduardo Habkost wrote:
> From: Stefano Stabellini <address@hidden>
> 
> Use realize to initialize the xen_platform device
> 
> Signed-off-by: Stefano Stabellini <address@hidden>
> Signed-off-by: Eduardo Habkost <address@hidden>

Applied to my tree


> Changes v1 -> v2:
> * Remove useless return
>   * Suggested-by: Paolo Bonzini <address@hidden>
> * Rename xen_platform_initfn() to xen_platform_realize()
> ---
>  hw/i386/xen/xen_platform.c | 6 ++----
>  1 file changed, 2 insertions(+), 4 deletions(-)
> 
> diff --git a/hw/i386/xen/xen_platform.c b/hw/i386/xen/xen_platform.c
> index 8682c42..3dc68cb 100644
> --- a/hw/i386/xen/xen_platform.c
> +++ b/hw/i386/xen/xen_platform.c
> @@ -382,7 +382,7 @@ static const VMStateDescription vmstate_xen_platform = {
>      }
>  };
>  
> -static int xen_platform_initfn(PCIDevice *dev)
> +static void xen_platform_realize(PCIDevice *dev, Error **errp)
>  {
>      PCIXenPlatformState *d = XEN_PLATFORM(dev);
>      uint8_t *pci_conf;
> @@ -407,8 +407,6 @@ static int xen_platform_initfn(PCIDevice *dev)
>                       &d->mmio_bar);
>  
>      platform_fixed_ioport_init(d);
> -
> -    return 0;
>  }
>  
>  static void platform_reset(DeviceState *dev)
> @@ -423,7 +421,7 @@ static void xen_platform_class_init(ObjectClass *klass, 
> void *data)
>      DeviceClass *dc = DEVICE_CLASS(klass);
>      PCIDeviceClass *k = PCI_DEVICE_CLASS(klass);
>  
> -    k->init = xen_platform_initfn;
> +    k->realize = xen_platform_realize;
>      k->vendor_id = PCI_VENDOR_ID_XEN;
>      k->device_id = PCI_DEVICE_ID_XEN_PLATFORM;
>      k->class_id = PCI_CLASS_OTHERS << 8 | 0x80;
> -- 
> 2.1.0
> 



reply via email to

[Prev in Thread] Current Thread [Next in Thread]