qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PULL 07/57] Rename mis->file to from_src_file


From: Juan Quintela
Subject: [Qemu-devel] [PULL 07/57] Rename mis->file to from_src_file
Date: Mon, 9 Nov 2015 18:28:11 +0100

From: "Dr. David Alan Gilbert" <address@hidden>

'file' becomes confusing when you have flows in each direction;
rename to make it clear.
This leaves just the main forward direction ms->file, which is used
in a lot of places and is probably not worth renaming given the churn.

Signed-off-by: Dr. David Alan Gilbert <address@hidden>
Reviewed-by: Juan Quintela <address@hidden>
Signed-off-by: Juan Quintela <address@hidden>
---
 include/migration/migration.h | 2 +-
 migration/migration.c         | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/include/migration/migration.h b/include/migration/migration.h
index 8334621..83fba23 100644
--- a/include/migration/migration.h
+++ b/include/migration/migration.h
@@ -48,7 +48,7 @@ typedef QLIST_HEAD(, LoadStateEntry) LoadStateEntry_Head;

 /* State for the incoming migration */
 struct MigrationIncomingState {
-    QEMUFile *file;
+    QEMUFile *from_src_file;

     /* See savevm.c */
     LoadStateEntry_Head loadvm_handlers;
diff --git a/migration/migration.c b/migration/migration.c
index f99d3ea..6fef544 100644
--- a/migration/migration.c
+++ b/migration/migration.c
@@ -95,7 +95,7 @@ MigrationIncomingState *migration_incoming_get_current(void)
 MigrationIncomingState *migration_incoming_state_new(QEMUFile* f)
 {
     mis_current = g_new0(MigrationIncomingState, 1);
-    mis_current->file = f;
+    mis_current->from_src_file = f;
     QLIST_INIT(&mis_current->loadvm_handlers);

     return mis_current;
-- 
2.5.0




reply via email to

[Prev in Thread] Current Thread [Next in Thread]