[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] [PATCH 08/25] 9pfs: merge hw/virtio/virtio-9p.h into hw/9pf
From: |
Aneesh Kumar K.V |
Subject: |
[Qemu-devel] [PATCH 08/25] 9pfs: merge hw/virtio/virtio-9p.h into hw/9pfs/virtio-9p.h |
Date: |
Tue, 12 Jan 2016 11:38:15 +0530 |
From: Wei Liu <address@hidden>
The deleted file only contained V9fsConf which wasn't virtio specific.
Merge that to the general header of 9pfs.
Fixed header inclusions as I went along.
Signed-off-by: Wei Liu <address@hidden>
Signed-off-by: Aneesh Kumar K.V <address@hidden>
---
hw/9pfs/virtio-9p-device.c | 1 -
hw/9pfs/virtio-9p.h | 8 +++++++-
hw/virtio/virtio-pci.h | 1 -
include/hw/virtio/virtio-9p.h | 24 ------------------------
4 files changed, 7 insertions(+), 27 deletions(-)
delete mode 100644 include/hw/virtio/virtio-9p.h
diff --git a/hw/9pfs/virtio-9p-device.c b/hw/9pfs/virtio-9p-device.c
index 92ac19b24b83..885b94068355 100644
--- a/hw/9pfs/virtio-9p-device.c
+++ b/hw/9pfs/virtio-9p-device.c
@@ -12,7 +12,6 @@
*/
#include "hw/virtio/virtio.h"
-#include "hw/virtio/virtio-9p.h"
#include "hw/i386/pc.h"
#include "qemu/sockets.h"
#include "virtio-9p.h"
diff --git a/hw/9pfs/virtio-9p.h b/hw/9pfs/virtio-9p.h
index d7a4dc1e9ad7..ac4cb006b30e 100644
--- a/hw/9pfs/virtio-9p.h
+++ b/hw/9pfs/virtio-9p.h
@@ -9,7 +9,6 @@
#include <glib.h>
#include "standard-headers/linux/virtio_9p.h"
#include "hw/virtio/virtio.h"
-#include "hw/virtio/virtio-9p.h"
#include "fsdev/file-op-9p.h"
#include "fsdev/virtio-9p-marshal.h"
#include "qemu/thread.h"
@@ -156,6 +155,13 @@ enum {
P9_FID_XATTR,
};
+typedef struct V9fsConf
+{
+ /* tag name for the device */
+ char *tag;
+ char *fsdev_id;
+} V9fsConf;
+
typedef struct V9fsXattr
{
int64_t copied_len;
diff --git a/hw/virtio/virtio-pci.h b/hw/virtio/virtio-pci.h
index a104ff20729b..7cf597461b94 100644
--- a/hw/virtio/virtio-pci.h
+++ b/hw/virtio/virtio-pci.h
@@ -23,7 +23,6 @@
#include "hw/virtio/virtio-scsi.h"
#include "hw/virtio/virtio-balloon.h"
#include "hw/virtio/virtio-bus.h"
-#include "hw/virtio/virtio-9p.h"
#include "hw/virtio/virtio-input.h"
#include "hw/virtio/virtio-gpu.h"
#ifdef CONFIG_VIRTFS
diff --git a/include/hw/virtio/virtio-9p.h b/include/hw/virtio/virtio-9p.h
deleted file mode 100644
index 65789db1317f..000000000000
--- a/include/hw/virtio/virtio-9p.h
+++ /dev/null
@@ -1,24 +0,0 @@
-/*
- * Virtio 9p
- *
- * Copyright IBM, Corp. 2010
- *
- * Authors:
- * Aneesh Kumar K.V <address@hidden>
- *
- * This work is licensed under the terms of the GNU GPL, version 2. See
- * the COPYING file in the top-level directory.
- *
- */
-
-#ifndef QEMU_VIRTIO_9P_DEVICE_H
-#define QEMU_VIRTIO_9P_DEVICE_H
-
-typedef struct V9fsConf
-{
- /* tag name for the device */
- char *tag;
- char *fsdev_id;
-} V9fsConf;
-
-#endif
--
2.5.0
- [Qemu-devel] [PULL 00/25] VirtFS update, Aneesh Kumar K.V, 2016/01/12
- [Qemu-devel] [PATCH 05/25] 9pfs: rename virtio-9p-proxy.{c, h} to 9p-proxy.{c, h}, Aneesh Kumar K.V, 2016/01/12
- [Qemu-devel] [PATCH 04/25] 9pfs: rename virtio-9p-posix-acl.c to 9p-posix-acl.c, Aneesh Kumar K.V, 2016/01/12
- [Qemu-devel] [PATCH 13/25] 9pfs: PDU processing functions should start pdu_ prefix, Aneesh Kumar K.V, 2016/01/12
- [Qemu-devel] [PATCH 22/25] 9pfs: rename virtio_9p_set_fd_limit to use v9fs_ prefix, Aneesh Kumar K.V, 2016/01/12
- [Qemu-devel] [PATCH 12/25] 9pfs: PDU processing functions don't need to take V9fsState as argument, Aneesh Kumar K.V, 2016/01/12
- [Qemu-devel] [PATCH 25/25] 9pfs: introduce V9fsVirtioState, Aneesh Kumar K.V, 2016/01/12
- [Qemu-devel] [PATCH 06/25] 9pfs: rename virtio-9p-synth.{c, h} to 9p-synth.{c, h}, Aneesh Kumar K.V, 2016/01/12
- [Qemu-devel] [PATCH 08/25] 9pfs: merge hw/virtio/virtio-9p.h into hw/9pfs/virtio-9p.h,
Aneesh Kumar K.V <=
- [Qemu-devel] [PATCH 24/25] 9pfs: factor out v9fs_device_{, un}realize_common, Aneesh Kumar K.V, 2016/01/12
- [Qemu-devel] [PATCH 01/25] 9pfs: rename virtio-9p-coth.{c, h} to coth.{c, h}, Aneesh Kumar K.V, 2016/01/12
- [Qemu-devel] [PATCH 15/25] 9pfs: factor out virtio_pdu_{, un}marshal, Aneesh Kumar K.V, 2016/01/12
- [Qemu-devel] [PATCH 03/25] 9pfs: rename virtio-9p-local.c to 9p-local.c, Aneesh Kumar K.V, 2016/01/12
- [Qemu-devel] [PATCH 09/25] 9pfs: remove dead code, Aneesh Kumar K.V, 2016/01/12
- [Qemu-devel] [PATCH 21/25] 9pfs: move handle_9p_output and make it static function, Aneesh Kumar K.V, 2016/01/12
- [Qemu-devel] [PATCH 18/25] 9pfs: break out 9p.h from virtio-9p.h, Aneesh Kumar K.V, 2016/01/12
- [Qemu-devel] [PATCH 10/25] fsdev: break out 9p-marshal.{c, h} from virtio-9p-marshal.{c, h}, Aneesh Kumar K.V, 2016/01/12
- [Qemu-devel] [PATCH 02/25] 9pfs: rename virtio-9p-handle.c to 9p-handle.c, Aneesh Kumar K.V, 2016/01/12
- [Qemu-devel] [PATCH 19/25] 9pfs: factor out virtio_9p_push_and_notify, Aneesh Kumar K.V, 2016/01/12