[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [Bug 1006655] Re: Can't convert to vmdk with the streamOpti

From: Thiago Martins
Subject: [Qemu-devel] [Bug 1006655] Re: Can't convert to vmdk with the streamOptimized subformat
Date: Fri, 01 Apr 2016 08:28:21 -0000

I have tried, many times, to use qemu-img to create StreamOptimized for
VMWare ESXi 6.0 OVAs.

It does NOT work.

After days of research, I replaced qemu-img, by vboxmanage, then, it

Now, I'm using something this:

vboxmanage convertfromraw packer/output-vm.raw packer/output-vm-disk1.vmdk 
--format vmdk --variant Stream

I also had to edit the headers, with dd:

dd if=output-vm-disk1.vmdk of=output-vm-disk1.descriptor bs=1 skip=512 
sed -i -e 's/ide/lsilogic/g' output-vm-disk1.descriptor
dd conv=notrunc,nocreat if=output-vm-disk1.descriptor of=output-disk1.vmdk bs=1 
seek=512 count=1024

This is the only way to build StreamOptimized VMDKs, for inclusion
inside of OVA, that works on VMWare 6.0.

The qemu-img can not be used.

Here is my full solution to this problem (if the same problem):


I'm just not entirely sure if we're talking about the same problem


You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  Can't convert to vmdk with the streamOptimized subformat

Status in QEMU:
  Fix Committed
Status in qemu package in Ubuntu:
  Fix Released
Status in qemu-kvm package in Ubuntu:

Bug description:
  Hi all,
  I'm trying to convert a qcow2 image file to the vmdk (on Ubuntu Server 12.04):

  # qemu-img convert -f qcow2 -O vmdk -o Stream spv-2912.qcow2 spv-2912-3.vmdk 
-o subformat=streamOptimized
  VMDK: can't write to allocated cluster for streamOptimized
  qemu-img: error while writing sector 65: Input/output error

  Same result with any input format. Others subformats work but the
  StreamOptimized is by far the most important one. The only workaround
  I found is to migrate to raw and then to use VBoxManage (VirtualBox).

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]