[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] run qemu on x64 system ( ARCH=i386 or ARCH=x86-64) and on x

From: Marwa Hamza
Subject: [Qemu-devel] run qemu on x64 system ( ARCH=i386 or ARCH=x86-64) and on x86 system
Date: Sun, 3 Apr 2016 14:50:09 +0100

hello , i tried to run qemu on x64 system ,

those are steps that i followed
i compile the kernel 4.4.1 with arch =i386
i download busybox 1.21.0
make ARCH=i386 menuconfig
I checked the option to compile Busybox as a static executable
make ARCH=i386 install
cd _install
mkdir proc sys dev lib etc etc/init.d
gedit etc/inittab
sudo chmod +x etc/inittab
sudo gedit etc/init.d/rcS
echo “hello” // hello display when starting the qemu
mount -t proc none /proc
mount -t sysfs none /sys
/sbin/mdev -s
sudo chmod +x _install/etc/init.d/rcS
find . | cpio -o –format=newc > ../rootfs.img
cd ..
gzip -c rootfs.img > rootfs.img.gz
./i386-softmmu/qemu-system-i386 -M pc -kernel /home/marwa/Bureau/lauterbach/i386_qemu/linux-4.1.18/arch/i386/boot/bzImage -initrd /home/marwa/Bureau/lauterbach/i386_qemu/busybox-1.21.0/rootfs.img.gz -append “root=/dev/ram rdinit=/sbin/init”

i have tried this command too

./i386-softmmu/qemu-system-i386 -M pc -kernel /home/marwa/Bureau/lauterbach/i386_qemu/linux-4.1.18/arch/i386/boot/bzImage -initrd /home/marwa/Bureau/lauterbach/i386_qemu/busybox-1.21.0/rootfs.img.gz -append “root=/dev/ram rdinit=/bin/sh”

but i got this msg in qemu ‘shell
starting init :/bin/sh exists but couldn’t execute it
kernel panic – not syncing no working init found

should i work with another file system ? or create a new one , I got the same error with x86 , , any one please can help me to get qemu working perfectly

reply via email to

[Prev in Thread] Current Thread [Next in Thread]