[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [Bug 1547526] Re: Java program does not execute on SPARC So

From: Mark Cave-Ayland
Subject: [Qemu-devel] [Bug 1547526] Re: Java program does not execute on SPARC Solaris 8
Date: Mon, 11 Apr 2016 11:03:57 -0000

Proposed patch posted to mailing list:
https://lists.nongnu.org/archive/html/qemu-devel/2016-04/msg01645.html -
please test and report back.

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  Java program does not execute on SPARC Solaris 8

Status in QEMU:

Bug description:

  I am trying to run a java program that never execute. The program uses
  jre1.1.5 which came with the java program. I don't know what to do to
  run this application. There are some random messages in command line
  that can be related to my problem (or not). They are:

        #1. Webstart launcher crashing.
        Also found here: 

        #2. Assertion failed: MUTEX_HELD(&svc_mutex), file rpc/svc_run.c, line 
        Which was already reported here: 

        #3. Some problems with libthread in Solaris. 
        I have tried a workaround setting LM_LIBRARY_PATH to use another 
version of libthread that Solaris 8 has.

  I don't know if this is a qemu problem or Solaris problem.
  My java application can be executed in command line or in GUI but I've tried 
both with no luck. I also have tryed other versions of JRE from 1.1.8 to 1.5 
but no luck either.

  I appreciate **any information** that can help me to execute the java 
  Thank you.

  I am using qemu-system-sparc (v2.5.50) with Solaris 8 
  The host is an Ubuntu 15.10 and I am using the openbios-sparc from Ubuntus 
ppa as shown bellow:

          openbios-sparc | 1.1+svn1334-1 |
  http://archive.ubuntu.com/ubuntu/ wily/universe amd64 Packages

  The command line used to launch qemu is:

        qemu-system-sparc \
                -M SS-5 \
                -m 256 \
                -boot c \
                -cdrom $(DATA_ISO) \
                -drive file=root-disk.img,index=0,media=disk,format=raw \
                -serial stdio \
                -monitor tcp::4444,server,nowait \
                -localtime \
                -net user \
                -net nic \

  DATA_ISO is the way I found to send my data to the guest.

  The root-disk.img is:

        Disk root-disk.img: 36 GiB, 38654705664 bytes, 75497472 sectors
        Geometry: 27 heads, 107 sectors/track, 24620 cylinders
        Units: sectors of 1 * 512 = 512 bytes
        Sector size (logical/physical): 512 bytes / 512 bytes
        I/O size (minimum/optimal): 512 bytes / 512 bytes
        Disklabel type: sun

        Device           Start      End  Sectors   Size Id Type       Flags
        root-disk.img1       0  2744549  2744550   1.3G  2 SunOS root      
        root-disk.img2 2744550  3047894   303345 148.1M  3 SunOS swap    u 
        root-disk.img3       0 71127179 71127180  33.9G  5 Whole disk      
        root-disk.img8 3047895 71127179 68079285  32.5G  8 SunOS home      

        image: root-disk.img
        file format: raw
        virtual size: 36G (38654705664 bytes)
        disk size: 1.2G

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]