[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Is anyone able to load a web page from a guest operatin

From: Thomas Huth
Subject: Re: [Qemu-devel] Is anyone able to load a web page from a guest operating system?
Date: Tue, 26 Apr 2016 22:12:47 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.7.0

On 26.04.2016 21:25, Programmingkid wrote:
> On Apr 26, 2016, at 3:00 PM, Dr. David Alan Gilbert wrote:
>> * Programmingkid (address@hidden) wrote:
>>> My three guest operating systems can't load a web page. I think this is a 
>>> bug with QEMU. Is there anyone who has the latest revision of QEMU that can 
>>> access the web from a guest? Or are you experiencing the same problem?
>> Works here.
> So you are using a very recent version of QEMU? Maybe something that was 
> pulled in the last day or so?
>> Now - how about some basic debug!
>> Does your guest see a network card?
> yes
>> Does DNS work?
> Doesn't look like it. If I use just an ip address it still doesn't work.
>> Does ping work?
> I can ping the virtual router at Any other ip address fails. 

That's normal for user-mode / slirp networking. You can't ping external
hosts with this mode.

>> Does a telnet/ssh from the guest work?
> telnet www.google.com 80     failed
> Didn't have an address to use ssh on.
>> What's the qemu command line you use?
> qemu-system-ppc -hda <hd1> -hdb <hd2> -m 512 -boot c -M mac99 -netdev 
> user,id=mynet0 -device usb-net,netdev=mynet0 -cpu 750 -prom-env boot-args=-v 
> -device ich9-usb-uhci1,id=newusb -device usb-audio,bus=newusb.0 
> and
> qemu-system-ppc -hda <hd1> -hdb <hd2> -m 512 -boot c -M mac99 -netdev 
> user,id=mynet0 -device rtl8139,netdev=mynet0 -cpu 750 -prom-env boot-args=-v 
> -device ich9-usb-uhci1,id=newusb -device usb-audio,bus=newusb.0 

Ok, that means you're using user-mode / slirp networking.
I just tried it with a pseries guest, and it seems to be working fine
for me with the current git version of QEMU (f419a626c76bcb266).

Now, what kind of host do you use? Mac OS X?
Also can you determine a revision when it was still working fine for
you? (and then maybe even bisect the problem?)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]