[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v7 03/19] block: Switch blk_*write_zeroes() to b

From: Eric Blake
Subject: Re: [Qemu-devel] [PATCH v7 03/19] block: Switch blk_*write_zeroes() to byte interface
Date: Mon, 23 May 2016 10:03:07 -0600
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.3.0

On 05/23/2016 09:42 AM, Kevin Wolf wrote:
> Am 06.05.2016 um 18:26 hat Eric Blake geschrieben:
>> Sector-based blk_write() should die; convert the one-off
>> variant blk_write_zeroes() to use an offset/count interface
>> instead.  Likewise for blk_co_write_zeroes() and
>> blk_aio_write_zeroes().
>> Signed-off-by: Eric Blake <address@hidden>
> You built a nice trap here: bdrv_*write_zeroes() is still sector based
> whereas blk_*write_zeroes() changed to be byte based without a rename.
> That broke my block jobs series which converts from bdrv_* to blk_*
> after the next (seemingly clean) rebase.
> I fixed my series now, but can we please convert bdrv_* as well
> before we get more victims in the same trap? Also (and perhaps more
> importantly) we could rename the functions to something like
> blk_*pwrite_zeroes(), indicating the switch to byte based.

Sure, the rename idea makes sense.  I should have something posted later

Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]