[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [Bug 1591628] Re: 2.6.0 hangs linux vm using vfio for pci p

From: Peter Maloney
Subject: [Qemu-devel] [Bug 1591628] Re: 2.6.0 hangs linux vm using vfio for pci passthrough of graphics card
Date: Mon, 13 Jun 2016 18:34:53 -0000

(changed your command with a different iso, and without the usb-host,
and with a pci passthrough of a usb controller, and with a vgarom for my
gpu otherwise I find it hangs if I repeatedly reboot a VM)

If I try with your command with an iso it works. If I replace the iso
with the VM's disk, it fails (see photo).

I'm not sure what is special about the VM. I tried a grsecurity kernel
4.1.6, and vanilla kernel 3.18.35, which both hang. And I tried single
user mode. I figured maybe it's something in grub. So I cleared out my
grub.cfg other than memtest86+ (grub.cfg attached)... and it still
fails, but this time it's a black screen except for the manjaro logo in
the bottom right (attached).

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  2.6.0 hangs linux vm using vfio for pci passthrough of graphics card

Status in QEMU:

Bug description:
  Not a duplicate of my old bug 1488363

  qemu version 2.5.1 works fine
  qemu version 2.6.0 fails

  seabios 1.9.2-1

  using kernel 4.5.5 with grsecurity

  I built using the arch packaging tools, but commented out all the
  patch code, so it should be vanilla.

  The problem is just that I start a Linux vm using either my radeon R7
  260x or radeon HD 6770, and with qemu 2.6.0, it looks normal until
  after the grub menu, and then the screen looks broken (with mostly
  black, and some pixely junk spread horizontally in a few places on the
  screen... first we thought maybe the monitor died). I'm not sure if
  it's before or only at the moment where the screen resolution changes
  (I could check that or record it on request). Also, the VM is not
  pingable and does not respond to "system_powerdown" on qemu monitor.

  However, the same setup works fine with windows 8. And it works fine
  without graphics cards passed through. A usb controller passed through
  works fine too.

  And then I ran a bisect...

          2d82f8a3cdb276bc3cb92d6f01bf8f66bf328d62 is the first bad commit
          commit 2d82f8a3cdb276bc3cb92d6f01bf8f66bf328d62
          Author: Alex Williamson <address@hidden>
          Date:   Thu Mar 10 09:39:08 2016 -0700

              vfio/pci: Convert all MemoryRegion to dynamic alloc and 
consistent functions
              Match common vfio code with setup, exit, and finalize functions 
              BAR, quirk, and VGA management.  VGA is also changed to dynamic
              allocation to match the other MemoryRegions.
              Signed-off-by: Alex Williamson <address@hidden>

          :040000 040000 0acfd49b6ecae780b6f52a34080ecec6b3ec3672 
e0cfdadede08f553463c0b23931eda81107f41b8 M      hw
  then confirm it by reverting that commit
          git checkout v2.6.0
          git revert 2d82f8a3cdb276bc3cb92d6f01bf8f66bf328d62
          git mergetool -t kdiff3
              "select all from C", save
              not sure if this is the right way to do this...but it compiles 
and works (bug fixed)
          git commit -m "revert 2d82f8a3cdb276bc3cb92d6f01bf8f66bf328d62 
resolve conflicts"

  And that 2.6.0 build with that one patch reverted works fine.

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]