[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] git master build failure

From: Mark Cave-Ayland
Subject: Re: [Qemu-devel] git master build failure
Date: Wed, 15 Jun 2016 12:46:00 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Icedove/38.8.0

On 15/06/16 12:26, Mark Cave-Ayland wrote:

> On 15/06/16 11:23, Andrew Jones wrote:
>>> Is that from a clean clone of the repository? I wonder if a change to a
>>> generated file isn't being picked up somewhere by "make distclean". My
>>> standard build script is this:
>> Not a clean clone, but a clean build dir. I build in a separate build dir.
>> mkdir builddir
>> cd builddir
>> ../srcdir/configure ...
>> make
>>> make distclean
>>> './configure' '--target-list=x86_64-softmmu sparc64-softmmu
>>> sparc-softmmu ppc-softmmu arm-softmmu' '--disable-pie'
>> Tried this config and still compiles for me.
> I've just tried it again using a git clone into a fresh directory and an
> out-of-tree build similar to as you did above and I still get the failure:
> cc -I/home/build/src/qemu/git/x/qemu/tcg
> -I/home/build/src/qemu/git/x/qemu/tcg/i386
> -I/home/build/src/qemu/git/x/qemu/linux-headers
> -I/home/build/src/qemu/git/x/build/linux-headers -I.
> -I/home/build/src/qemu/git/x/qemu
> -I/home/build/src/qemu/git/x/qemu/include
> -I/home/build/src/qemu/git/x/qemu/target-ppc -Itarget-ppc
> -I/usr/include/pixman-1   -I/home/build/src/qemu/git/x/qemu/dtc/libfdt
> -Wstrict-prototypes -Wredundant-decls -Wall -Wundef -Wwrite-strings
> -Wmissing-prototypes -fno-strict-aliasing -fno-common  -Wendif-labels
> -Wmissing-include-dirs -Wempty-body -Wnested-externs -Wformat-security
> -Wformat-y2k -Winit-self -Wignored-qualifiers -Wold-style-declaration
> -Wold-style-definition -Wtype-limits -fstack-protector-all
> -I/usr/include/p11-kit-1      -I/usr/include/libpng12
> -I../linux-headers -I.. -I/home/build/src/qemu/git/x/qemu/target-ppc
> -DNEED_CPU_H -I/home/build/src/qemu/git/x/qemu/include -MMD -MP -MT
> target-ppc/timebase_helper.o -MF target-ppc/timebase_helper.d -O2
> -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -pthread -I/usr/include/glib-2.0
> -I/usr/lib/x86_64-linux-gnu/glib-2.0/include   -g   -c -o
> target-ppc/timebase_helper.o
> /home/build/src/qemu/git/x/qemu/target-ppc/timebase_helper.c
> /home/build/src/qemu/git/x/qemu/hw/arm/virt.c: In function
> ‘virt_2_6_class_init’:
> /home/build/src/qemu/git/x/qemu/hw/arm/virt.c:1509:5: error: array
> subscript is above array bounds [-Werror=array-bounds]
> cc1: all warnings being treated as errors
> make[1]: *** [hw/arm/virt.o] Error 1
> make[1]: Leaving directory `/home/build/src/qemu/git/x/build/arm-softmmu'
> make: *** [subdir-arm-softmmu] Error 2
> Not sure if it's a contributing factor but my standard make invocation
> tries to build with 2 cores once configure has run, i.e. "make V=1 -j2
> install".

And here's a log of the build output for the above build (fresh git
clone, external build dir):



reply via email to

[Prev in Thread] Current Thread [Next in Thread]