[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Qemu and heavily increased RSS usage

From: Peter Lieven
Subject: [Qemu-devel] Qemu and heavily increased RSS usage
Date: Tue, 21 Jun 2016 10:21:55 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.8.0


while upgrading from Qemu 2.2.0 to Qemu I noticed that the RSS memory 
usage has heavily increased.
We use hugepages so the RSS memory does not include VM memory. In Qemu 2.2.0 it 
used to be ~30MB per vServer
and increased to up to 300 - 400MB for Qemu (same with master). The 
memory increases over time, but seems
not to grow indefinetly. I tried to bisect, but had no result so far that made 
sense. I also tried valgrind / massif, but
valgrind does not see the allocation (at least at exit) and massif fails to 
rund due to - so it pretends - heap corruption.

Any help or ideas how to debug further would be appreciated.

Cmdline is:
./x86_64-softmmu/qemu-system-x86_64 -enable-kvm -M pc-i440fx-2.1 -nodefaults -netdev type=tap,id=guest3,script=no,downscript=no,ifname=tap0,vnet_hdr -device virtio-net-pci,netdev=guest3,mac=52:54:00:ff:08:5e -iscsi initiator-name=iqn.2005-03.org.xx:0025b5d0011f -drive format=raw,discard=on,file=iscsi://,if=none,cache=writeback,aio=native,id=disk0 -object iothread,id=iothread0 -device virtio-blk-pci,drive=disk0,iothread=iothread0 -global virtio-blk-pci.scsi=off -serial null -parallel null -m 4096 -smp 4,sockets=1,cores=4,threads=1 -monitor tcp:0:4004,server,nowait,nodelay -qmp tcp:0:3004,server,nowait,nodelay -name lieven-test -boot order=c,once=dc,menu=off -k de -mem-path /hugepages -mem-prealloc -cpu Westmere,enforce -rtc base=utc -usb -usbdevice tablet -no-hpet -vga vmware


reply via email to

[Prev in Thread] Current Thread [Next in Thread]