[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Qemu and heavily increased RSS usage

From: Peter Lieven
Subject: Re: [Qemu-devel] Qemu and heavily increased RSS usage
Date: Thu, 23 Jun 2016 16:58:24 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.8.0

Am 21.06.2016 um 15:18 schrieb Dr. David Alan Gilbert:
* Peter Lieven (address@hidden) wrote:

while upgrading from Qemu 2.2.0 to Qemu I noticed that the RSS memory 
usage has heavily increased.
We use hugepages so the RSS memory does not include VM memory. In Qemu 2.2.0 it 
used to be ~30MB per vServer
and increased to up to 300 - 400MB for Qemu (same with master). The 
memory increases over time, but seems
not to grow indefinetly. I tried to bisect, but had no result so far that made 
sense. I also tried valgrind / massif, but
valgrind does not see the allocation (at least at exit) and massif fails to 
rund due to - so it pretends - heap corruption.

Any help or ideas how to debug further would be appreciated.
I think I'd try stripping devices off; can you get a similar difference
to happen with a guest with no USB, no hugepages, no VGA and a simple
locally stored IDE disk?

If you're having trouble bisecting is it possible it's a change
in one of the libraries it's linked against?

There was someone asking the other day on #qemu who had a setup that
was apparently using much more RAM than expected and we didn't
manage to track it down but I can't remember the version being used.

I currently trying to track the increased usage from release to release. The 
first increase of RSS usage from ~25MB to ~35MB directly
after machine setup is introduced by this patch:

commit ba3f4f64b0e941b9e03568b826746941bef071f9
Author: Paolo Bonzini <address@hidden>
Date:   Wed Jan 21 12:09:14 2015 +0100

    exec: RCUify AddressSpaceDispatch

    Note that even after this patch, most callers of address_space_*
    functions must still be under the big QEMU lock, otherwise the memory
    region returned by address_space_translate can disappear as soon as
    address_space_translate returns.  This will be fixed in the next part
    of this series.

    Reviewed-by: Fam Zheng <address@hidden>
    Signed-off-by: Paolo Bonzini <address@hidden>

@Paolo, @Fam, any idea?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]