[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [PATCH] target-ppc: Eliminate redundant and incorrect f
Re: [Qemu-devel] [PATCH] target-ppc: Eliminate redundant and incorrect function booke206_page_size_to_tlb
Mon, 27 Jun 2016 15:32:13 +1000
On Sun, Jun 26, 2016 at 09:38:03PM -0500, address@hidden wrote:
> David Gibson <address@hidden> wrote on 06/26/2016 08:36:52
> > From: David Gibson <address@hidden>
> > To: Aaron Larson <address@hidden>
> > Cc: address@hidden, address@hidden, address@hidden
> > Date: 06/26/2016 08:58 PM
> > Subject: Re: [PATCH] target-ppc: Eliminate redundant and incorrect
> function booke206_page_size_to_tlb
> > On Fri, Jun 24, 2016 at 12:11:00PM -0700, Aaron Larson wrote:
> > >
> > > Eliminate redundant and incorrect booke206_page_size_to_tlb function
> > > from ppce500_spin.c in preference to previously existing but newly
> > > exported definition from e500.c
> > >
> > > Signed-off-by: Aaron Larson <address@hidden>
> > Uh.. sorry.. can you provide a reference explaining why the removed
> > version is wrong? Doesn't this depend on which MMU Architecture
> > Version we're emulating?
> Sure, the code is internally inconsistent (shift assumed didn't match
> shift defined). I will provide an update commit message, similar to the
> original posting I made a few days ago with the "direction"
Right, I can see that the two old versions were different, which was
clearly wrong. What I'm looking for is an explanation of why the one
you've picked is the right one, not the other one.
David Gibson | I'll have my music baroque, and my code
david AT gibson.dropbear.id.au | minimalist, thank you. NOT _the_ _other_
| _way_ _around_!
Description: PGP signature