[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 6/9] Convert cpu_memory_rw_debug to use MMUAcces

From: David Gibson
Subject: Re: [Qemu-devel] [PATCH 6/9] Convert cpu_memory_rw_debug to use MMUAccessType
Date: Mon, 11 Jul 2016 12:24:01 +1000
User-agent: Mutt/1.6.1 (2016-04-27)

On Sun, Jul 10, 2016 at 08:32:32PM +0100, Peter Maydell wrote:
> On 8 July 2016 at 04:42, David Gibson <address@hidden> wrote:
> > My only concern here is that the constants are named
> > *MMU*_DATA_... whereas these are physical memory accesses not
> > involving the MMU.  I can't actually see any current users of
> > MMUAccessType which makes me a bit confused as to what it's intended
> > meaning was
> you'll see the uses. A lot of the softmmu code uses the
> convention of 0=read,1=write,2=insn (which developed I
> think historically from a bool "is_write", which you'll
> still see in some function argument names, that was
> augmented to handle insn-fetch separately). The enum
> gives us some symbolic names for the constant values.
> (There's a proposed patch somewhere to change the
> 'int is_write' arguments to actually use the enum type.)

Ah, yes, I see.  Still surprisingly few, actually.

My concern about the potentially misleading name still stands..

David Gibson                    | I'll have my music baroque, and my code
david AT gibson.dropbear.id.au  | minimalist, thank you.  NOT _the_ _other_
                                | _way_ _around_!

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]