[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [Qemu-ppc] [PULL 05/23] ppc: Enforce setting MSR:EE, IR

From: Programmingkid
Subject: Re: [Qemu-devel] [Qemu-ppc] [PULL 05/23] ppc: Enforce setting MSR:EE, IR and DR when MSR:PR is set
Date: Mon, 11 Jul 2016 10:42:39 -0400

On Jul 11, 2016, at 3:04 AM, Mark Cave-Ayland wrote:

> On 10/07/16 23:14, Cédric Le Goater wrote:
>> Mark, 
>> For OS 9, do you plan to commit these openbios patches soon ? 
>>      https://lists.nongnu.org/archive/html/qemu-devel/2015-11/msg02824.html
>> as we just gave them a good test. Or may be, include them under 
>> a github branch to make them easier to find.
> All of the OS 9 patches for QEMU and OpenBIOS have been upstreamed,
> except this one for OpenBIOS:
> https://www.coreboot.org/pipermail/openbios/2015-June/008722.html. I
> currently keep a manually build binary at
> https://www.ilande.co.uk/tmp/openbios/openbios-ppc for people who can't
> build their own.
>> Also, I found out that some OS 9 isos are not supported by qemu. 
>> These are ok : 
>> http://www.emaculation.com/forum/viewtopic.php?f=34&t=7047&sid=0ef8922b24a51d2a9d546300aea69c64&start=250
>> But the one under :
>>      http://c-obrien.org/qemu-os9/testing/
>> does not boot. It loops on some CUDA commands and then hangs. 
>> I did not dig further. Is that a known issue ? 
> Hmmm if that's the same 9.2.1 image we were using for last year's GSoC
> then it has been working fine here? From what I've seen both 9.2.1 and
> 9.2.2 now boot fine, but please test and report if that's not the case.
I tried the Mac OS 9.2.1 iso and it does not boot. I used only your patch set.

I would also like to report that I could not make networking work on Mac OS 
9.0.4. I tried both the usb-net and rtl8139 nics. This is the command-line I 
used: -netdev user,id=mynet0 -device usb-net,netdev=mynet0 and -netdev 
user,id=mynet0 -device rtl8139,netdev=mynet0.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]