qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [RFC v6-based v1 5/5] rename 'vfio_mpci' to 'vfio_mdev' sin


From: Jike Song
Subject: [Qemu-devel] [RFC v6-based v1 5/5] rename 'vfio_mpci' to 'vfio_mdev' since it is now BUS-agnostic
Date: Tue, 16 Aug 2016 16:14:17 +0800

Signed-off-by: Jike Song <address@hidden>
---
 drivers/vfio/mdev/Kconfig                      | 10 +++++-----
 drivers/vfio/mdev/Makefile                     |  5 ++---
 drivers/vfio/mdev/{vfio_mpci.c => vfio_mdev.c} |  0
 3 files changed, 7 insertions(+), 8 deletions(-)
 rename drivers/vfio/mdev/{vfio_mpci.c => vfio_mdev.c} (100%)

diff --git a/drivers/vfio/mdev/Kconfig b/drivers/vfio/mdev/Kconfig
index 431ed59..b2fe0c6 100644
--- a/drivers/vfio/mdev/Kconfig
+++ b/drivers/vfio/mdev/Kconfig
@@ -1,5 +1,5 @@
 
-config VFIO_MDEV
+config MDEV
     tristate "Mediated device driver framework"
     depends on VFIO
     default n
@@ -9,10 +9,10 @@ config VFIO_MDEV
 
         If you don't know what do here, say N.
 
-config VFIO_MPCI
-    tristate "VFIO support for Mediated PCI devices"
-    depends on VFIO && PCI && VFIO_MDEV
+config VFIO_MDEV
+    tristate "VFIO Bus driver for Mediated devices"
+    depends on VFIO && MDEV
     default n
     help
-        VFIO based driver for mediated PCI devices.
+        VFIO Bus driver for mediated devices.
 
diff --git a/drivers/vfio/mdev/Makefile b/drivers/vfio/mdev/Makefile
index 264fb03..ee9f89f 100644
--- a/drivers/vfio/mdev/Makefile
+++ b/drivers/vfio/mdev/Makefile
@@ -1,6 +1,5 @@
 
 mdev-y := mdev_core.o mdev_sysfs.o mdev_driver.o
 
-obj-$(CONFIG_VFIO_MDEV) += mdev.o
-obj-$(CONFIG_VFIO_MPCI) += vfio_mpci.o
-
+obj-$(CONFIG_MDEV) += mdev.o
+obj-$(CONFIG_VFIO_MDEV) += vfio_mdev.o
diff --git a/drivers/vfio/mdev/vfio_mpci.c b/drivers/vfio/mdev/vfio_mdev.c
similarity index 100%
rename from drivers/vfio/mdev/vfio_mpci.c
rename to drivers/vfio/mdev/vfio_mdev.c
-- 
1.9.1




reply via email to

[Prev in Thread] Current Thread [Next in Thread]