[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Concerning " [PULL 6/6] curses: Use cursesw instead of

From: Sergey Smolov
Subject: Re: [Qemu-devel] Concerning " [PULL 6/6] curses: Use cursesw instead of curses"
Date: Wed, 09 Nov 2016 10:12:58 +0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20120713 Thunderbird/14.0

On 08.11.2016 20:28, Cornelia Huck wrote:
On Tue, 8 Nov 2016 16:49:51 +0000
Stefan Hajnoczi <address@hidden> wrote:

On Tue, Nov 08, 2016 at 10:40:20AM +0300, Sergey Smolov wrote:
Dear List!

I've encountered the same problem as was discussed in this thread:

Does anybody succeeded in solving the problem?

 From my side, the problem appears when I run the 'configure' script with
'--target-list=aarch64-softmmu' option. The script returns the following
message to me:

ERROR: configure test passed without -Werror but failed with -Werror.
        This is probably a bug in the configure script. The failing command
        will be at the bottom of config.log.
        You can run configure with --disable-werror to bypass this check.

I've attached a config.log to this e-mail.

cc -Werror -fPIE -DPIE -m64 -mcx16 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 
-D_LARGEFILE_SOURCE -Wstrict-prototypes -Wredundant-decls -Wall -Wundef 
-Wwrite-strings -Wmissing-prototypes -fno-strict-aliasing -fno-common -fwrapv 
-Wendif-labels -Wmissing-include-dirs -Wempty-body -Wnested-externs 
-Wformat-security -Wformat-y2k -Winit-self -Wignored-qualifiers 
-Wold-style-declaration -Wold-style-definition -Wtype-limits 
-fstack-protector-all -I/usr/include/libpng14 -o config-temp/qemu-conf.exe 
config-temp/qemu-conf.c -Wl,-z,relro -Wl,-z,now -pie -m64 -g -lncursesw
config-temp/qemu-conf.c: In function ‘main’:
config-temp/qemu-conf.c:9:3: error: implicit declaration of function ‘addwstr’ 
config-temp/qemu-conf.c:9:3: error: nested extern declaration of ‘addwstr’ 
config-temp/qemu-conf.c:10:3: error: implicit declaration of function 
‘addnwstr’ [-Werror=implicit-function-declaration]
config-temp/qemu-conf.c:10:3: error: nested extern declaration of ‘addnwstr’ 
cc1: all warnings being treated as errors

   Wide-character functions from the X/Open standard -- these are only
   available when PDCurses is built with PDC_WIDE defined, and the
   prototypes are only available from curses.h when PDC_WIDE is defined
   before its inclusion in your app:

        addnwstr                addstr
        addwstr                 addstr

QEMU does not define PDC_WIDE.  Try adding ./configure
I think the problem is rather the incorrect include detection in
configure -- see <address@hidden> ("[PATCH]
Fix legacy ncurses detection.") and the following thread.

Sergey: Are you running on SLES?

Dear Cornelia,

I'm running on OpenSUSE 12.2 x86_64.

I've tried to use this patch, but the situation keeps the same.

Sergey Smolov

reply via email to

[Prev in Thread] Current Thread [Next in Thread]