[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [PATCH v2 1/2] memory: provide common macros for mtree_
Re: [Qemu-devel] [PATCH v2 1/2] memory: provide common macros for mtree_print_mr()
Thu, 12 Jan 2017 12:19:21 +0100
Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.5.1
On 12/01/2017 10:46, Peter Xu wrote:
> Yes, above suggestion makes sense to me, since after all the RW
> permissions are derived from the type of memory regions, and the type
> itself tells more things than the RW bits. So I totally agree we can
> replace the "RW" chars with its type directly (if no one else
> disagree, of course).
> While for below patch, do you want me to include it as well as a
> standalone patch, for the purpose of refactoring
> memory_access_is_direct()? Since IMHO it's tiny clearer and more
> readable than before.
It is more readable, but my plan was to turn these fields into a single
field (with bits) to speed up memory_access_is_direct. For that we'd
need to undo your change. So I'm undecided.