[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [PATCH v6 1/2] block/vxhs.c: Add support for a new bloc
Re: [Qemu-devel] [PATCH v6 1/2] block/vxhs.c: Add support for a new block device type called "vxhs"
Tue, 31 Jan 2017 17:55:47 -0800
There has been some work going on on the VxHS libvirt patches and we
are making good progress.
A suggestion has been made on the libvirt community to check if we can
change the qemu VxHS device specification syntax as follows.
The reasoning being that since we have only one host (true as the
failover is now being handled completely/transparently) within the
libqnio library), the "server" part is redundant.
Excerpt from John Ferlan's email -
#2. Is the desire to ever support more than 1 host? If not, then is the
"server" syntax you've borrowed from the Gluster code necessary? Could
you just go with the single "host" like NBD and SSH. As it relates to
the qemu command line - I'm not quite as clear. From the example I see
in commit id '7b7da9e28', the gluster syntax would have:
whereas, the VxHS syntax is:
FWIW: I also note there is no ".type=tcp" in your output - so perhaps
the "default" is tcp unless otherwise specified, but I'm sure of the
qemu syntax requirements in this area. I assume that since there's only
1 server, the ".0, .1, .2" become unnecessary (something added by commit
id 'f1bbc7df4' for multiple gluster hosts).
I haven't closedly followed the qemu syntax discussion, but it would it
would be possible to use:
Similar to how NBD (see commit id 'a1674fd9') and SSH (see commit id
'bc225b1b5') are handled.
If this proposal looks OK to the community, then I will make this user
interface change in the next VxHS qemu patch.
On Wed, Nov 16, 2016 at 9:05 AM, ashish mittal <address@hidden> wrote:
> On Wed, Nov 16, 2016 at 3:27 AM, Stefan Hajnoczi <address@hidden> wrote:
>> On Wed, Nov 16, 2016 at 9:49 AM, Fam Zheng <address@hidden> wrote:
>>> On Wed, 11/16 10:04, Markus Armbruster wrote:
>>>> ashish mittal <address@hidden> writes:
>>>> > Thanks for concluding on this.
>>>> > I will rearrange the qnio_api.h header accordingly as follows:
>>>> > +#include "qemu/osdep.h"
>>>> Headers should not include osdep.h.
>>> This is about including "osdep.h" _and_ "qnio_api.h" in block/vxhs.c, so
>>> Ashish means looks good to me.
>> Yes, I think "will rearrange the qnio_api.h header" was a typo and was
>> supposed to be block/vxhs.c.
> Thanks for the correction. Yes, i meant rearrange headers in block/vxhs.c.
|[Prev in Thread]
||[Next in Thread]|
- Re: [Qemu-devel] [PATCH v6 1/2] block/vxhs.c: Add support for a new block device type called "vxhs",
ashish mittal <=