[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 00/24] QemuOpts util/cutils: Fix and clean up nu

From: Paolo Bonzini
Subject: Re: [Qemu-devel] [PATCH 00/24] QemuOpts util/cutils: Fix and clean up number conversions
Date: Tue, 14 Feb 2017 13:37:08 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.7.0

On 14/02/2017 11:25, Markus Armbruster wrote:
> QemuOpts has its own code to convert strings to numbers, and being
> QemuOpts, it gets it wrong.  util/cutils is less wrong.  Fix it up
> some, and reuse it for QemuOpts.

Nice.  I only had a couple minor remarks.


> Markus Armbruster (24):
>   tests/test-qemu-opts: Cover qemu_opts_parse()
>   QemuOpts: Assert value string isn't null
>   tests/test-cutils: Add missing qemu_strtol()... endptr checks
>   tests/test-cutils: Clean up qemu_strtoul() result checks
>   util/cutils: Rewrite documentation of qemu_strtol() & friends
>   util/cutils: Rename qemu_strtoll(), qemu_strtoull()
>   util/cutils: Clean up variable names around qemu_strtol()
>   util/cutils: Clean up control flow around qemu_strtol() a bit
>   QemuOpts: Fix to reject numbers that overflow uint64_t
>   tests/test-cutils: Add missing qemu_strtosz()... endptr checks
>   tests/test-cutils: Cover qemu_strtosz() invalid input
>   tests/test-cutils: Cover qemu_strtosz() with trailing crap
>   tests/test-cutils: Cover qemu_strtosz() around range limits
>   util/cutils: New qemu_strtosz_metric()
>   util/cutils: Rename qemu_strtosz() to qemu_strtosz_mebi()
>   util/cutils: New qemu_strtosz()
>   util/cutils: Drop QEMU_STRTOSZ_DEFSUFFIX_* macros
>   tests/test-cutils: Use qemu_strtosz() more often
>   tests/test-cutils: Drop suffix from test_qemu_strtosz_simple()
>   qemu-img: Wrap cvtnum() around qemu_strtosz()
>   util/cutils: Let qemu_strtosz*() optionally reject trailing crap
>   util/cutils: Return qemu_strtosz*() error and value separately
>   util/cutils: Change qemu_strtosz*() from int64_t to uint64_t
>   QemuOpts: Fix checking of sizes for overflow and trailing crap

reply via email to

[Prev in Thread] Current Thread [Next in Thread]