[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [PATCH for-2.10 14/19] crypto: cipher: add af_alg ciphe
From: |
Longpeng (Mike) |
Subject: |
Re: [Qemu-devel] [PATCH for-2.10 14/19] crypto: cipher: add af_alg cipher support |
Date: |
Mon, 10 Apr 2017 18:52:29 +0800 |
User-agent: |
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20120327 Thunderbird/11.0.1 |
On 2017/4/10 18:18, Daniel P. Berrange wrote:
> On Mon, Apr 10, 2017 at 05:00:52PM +0800, Longpeng(Mike) wrote:
>> Adds afalg-backend cipher support: introduces some private APIs
>> firstly, and then intergrates them into qcrypto_cipher_afalg_driver.
>>
>> Signed-off-by: Longpeng(Mike) <address@hidden>
>> ---
>> crypto/Makefile.objs | 1 +
>> crypto/cipher-afalg.c | 229
>> ++++++++++++++++++++++++++++++++++++++++++++
>> crypto/cipher.c | 30 +++++-
>> include/crypto/afalg-comm.h | 11 +++
>> include/crypto/cipher.h | 7 ++
>> tests/test-crypto-cipher.c | 10 +-
>> 6 files changed, 286 insertions(+), 2 deletions(-)
>> create mode 100644 crypto/cipher-afalg.c
>>
>
...
>
>
> All methods in this file should be named 'qcrypto_afalg_...'
>
Hi Daniel,
Now the libiary-backend methods are named as "nettle(gcrypt,glib,builtin)_...",
so if I rename them with "qcrypto_afalg_" prefix , then the libiary-backend
methods need with "qcrypto_nettle(gcrypt,glib,builtin)_" prefix , right ?
>> +
>> +struct QCryptoCipherDriver qcrypto_cipher_afalg_driver = {
>> + .cipher_encrypt = afalg_cipher_encrypt,
>> + .cipher_decrypt = afalg_cipher_decrypt,
>> + .cipher_setiv = afalg_cipher_setiv,
>> + .cipher_free = afalg_comm_ctx_free,
>> +};
>
>
>
>
> Regards,
> Daniel
--
Regards,
Longpeng(Mike)