[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v3 4/7] s390x/pci: rework PCI STORE BLOCK

From: Pierre Morel
Subject: Re: [Qemu-devel] [PATCH v3 4/7] s390x/pci: rework PCI STORE BLOCK
Date: Mon, 27 Nov 2017 09:17:44 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.4.0

On 23/11/2017 10:26, Thomas Huth wrote:
On 22.11.2017 23:05, Pierre Morel wrote:
Enhance the fault detection.

Fixup the precedence to check the destination path existance
before checking for the source accessibility.

Add the maxstbl entry to both the Query PCI Function Group
response and the PCIBusDevice structure.

Initialize the maxstbl to 128 per default until we get
the actual data from the hardware.

Signed-off-by: Pierre Morel <address@hidden>
Reviewed-by: Yi Min Zhao <address@hidden>
  hw/s390x/s390-pci-bus.h  |  1 +
  hw/s390x/s390-pci-inst.c | 63 ++++++++++++++++++++++++++++++------------------
  hw/s390x/s390-pci-inst.h |  2 +-
  3 files changed, 41 insertions(+), 25 deletions(-)
@@ -722,6 +733,10 @@ int pcistb_service_call(S390CPU *cpu, uint8_t r1, uint8_t 
r3, uint64_t gaddr,
setcc(cpu, ZPCI_PCI_LS_OK);
      return 0;
+    program_interrupt(env, PGM_SPECIFICATION, 6);

The label is called "addressing_error", but then you insert a
PGM_SPECIFICTATION ? According to the name of the label, I'd rather
expected a PGM_ADDRESSING here ... so maybe rename the label to
"spec_error" or something similar?

+    return 0;


I used this name because the error is really related to an addressing problem, alignment, crossing a boundary.
I agree, if no opinion against it I will change it to spec_error.



Pierre Morel
Linux/KVM/QEMU in Böblingen - Germany

reply via email to

[Prev in Thread] Current Thread [Next in Thread]