[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] device_del fail

From: Lying
Subject: Re: [Qemu-devel] device_del fail
Date: Thu, 30 Nov 2017 16:36:54 +0800 (CST)

hello, i try again on arch Linux , after i add gpu, display is not 
light,following message from "info pci":
  Bus  0, device   5, function 0:
    VGA controller: PCI device 10de:1401
      IRQ 11.
      BAR0: 32 bit memory at 0xffffffffffffffff [0x00fffffe].
      BAR1: 64 bit prefetchable memory at 0xffffffffffffffff [0x0ffffffe].
      BAR3: 64 bit prefetchable memory at 0xffffffffffffffff [0x01fffffe].
      BAR5: I/O at 0xffffffffffffffff [0x007e].
      BAR6: 32 bit memory at 0xffffffffffffffff [0x0001fffe].
      id "gpu1"
  Bus  0, device   6, function 0:
    Audio controller: PCI device 10de:0fba
      IRQ 10.
      BAR0: 32 bit memory at 0x3e820000 [0x3e823fff].
      id "gpu2"

Then i connect that guest with ssh:
Last login: Thu Nov 30 22:29:03 2017(it's normal)

At 2017-11-30 10:32:26, "Fam Zheng" <address@hidden> wrote:
>Let's keep address@hidden on the list so other people can chime in.
>On Thu, 11/30 10:05, Lying wrote:
>> At 2017-11-29 14:29:17, "Fam Zheng" <address@hidden> wrote:
>> >On Wed, 11/29 13:43, Lying wrote:
>> >> Hello everybody, I encounter a error on my vm guest
>> >> I remove my device on my guest is failed, following is detail message.
>> >> I didn't add my audio device before running my guest, So i add audio with 
>> >> "device_add" after running
>> >> Then i can use it, so i remove it with "device_del", but when i do it 
>> >> again, i
>> >> can't use my audio device and cannot remove it.
>> >
>> >
>> >I haven't tried unplugging an audio device myself but in general PCI hot 
>> >unplug
>> >needs guest cooperation so some infomation about guest is also helpful.  
>> >Which
>> >guest OS is this?
>> >
>> >What are the exact commands that you used and what are the messages from
>> >host/guest when you device_del?
>> >
>> >Fam
>> hello, thanks for your reply, and i'm sorry that i not notice at yesterday .
>> following is my information:
>>     guest : window-7
>>     host : Ubuntu-16.04
>>     qemu : 2.11.0-rc0
>>     libvirt : 3.9
>>    seabios : 1.10.74 (from qemu)
>> exact commands:
>>     add:"device_add 
>> driver=vfio-pci,host=02:00.0,x-vga=on,multifunction=yes,id=gpu1"
>>     remove:"device_del gpu1"
>> and not messages when i running device_del. But i can see it still exist 
>> while running commands "info pci"
>Probably the guest didn't respond to the hot-unplug event. In your original
>question you said it is an audio device but your command suggests it is a GPU
>device. I'm not sure Windows driver can handle this. Have you tried different
>guests, such as Linux?
>Cc Alex who may know more.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]