[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v4 2/7] monitor: rename *_pop_one to *_pop_any

From: Eric Blake
Subject: Re: [Qemu-devel] [PATCH v4 2/7] monitor: rename *_pop_one to *_pop_any
Date: Tue, 19 Jun 2018 06:48:35 -0500
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.8.0

On 06/19/2018 12:34 AM, Peter Xu wrote:
The old names are confusing since both of the old functions are poping


an item from multiple queues rather than a single queue.  In that
sense, *_pop_any() suites better than *_pop_one().

Since at it, touch up the function monitor_qmp_response_pop_any() a bit
to let the callers pass in a QMPResponse struct instead of returning a
struct.  Change the return value to boolean to mark whether we have
poped a valid response instead.


Suggested-by: Markus Armbruster <address@hidden>
Signed-off-by: Peter Xu <address@hidden>
  monitor.c | 20 +++++++++-----------
  1 file changed, 9 insertions(+), 11 deletions(-)

Eric Blake, Principal Software Engineer
Red Hat, Inc.           +1-919-301-3266
Virtualization:  qemu.org | libvirt.org

reply via email to

[Prev in Thread] Current Thread [Next in Thread]