qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 1/9] qom/user-creatable: add a few helper macros


From: Eduardo Habkost
Subject: Re: [Qemu-devel] [PATCH 1/9] qom/user-creatable: add a few helper macros
Date: Thu, 1 Nov 2018 12:02:03 -0300
User-agent: Mutt/1.9.2 (2017-12-15)

On Thu, Nov 01, 2018 at 01:16:37PM +0100, Igor Mammedov wrote:
> On Tue, 30 Oct 2018 20:07:17 -0300
> Eduardo Habkost <address@hidden> wrote:
> 
> > On Tue, Oct 30, 2018 at 03:22:43PM +0100, Igor Mammedov wrote:
> > > On Tue, 30 Oct 2018 13:26:40 +0400
> > > Marc-André Lureau <address@hidden> wrote:
> > >   
> > > > Hi
> > > > 
> > > > On Tue, Oct 30, 2018 at 5:37 AM Eduardo Habkost <address@hidden> wrote: 
> > > >  
> > > > >
> > > > > On Mon, Oct 29, 2018 at 10:56:57AM +0100, Igor Mammedov wrote:    
> > > > > > On Fri, 26 Oct 2018 12:13:21 -0300
> > > > > > Eduardo Habkost <address@hidden> wrote:
> > > > > >    
> > > > > > > On Mon, Oct 22, 2018 at 03:33:30PM +0100, Igor Mammedov wrote:    
> > > > > > > > On Wed, 12 Sep 2018 16:55:23 +0400
> > > > > > > > Marc-André Lureau <address@hidden> wrote:
[...]
> > > > > > > > >  void user_creatable_complete(Object *obj, Error **errp)
> > > > > > > > >  {
> > > > > > > > > -
> > > > > > > > >      UserCreatableClass *ucc;
> > > > > > > > > -    UserCreatable *uc =
> > > > > > > > > -        (UserCreatable *)object_dynamic_cast(obj, 
> > > > > > > > > TYPE_USER_CREATABLE);
> > > > > > > > >
> > > > > > > > > -    if (!uc) {
> > > > > > > > > +    if (!IS_USER_CREATABLE(obj)) {
> > > > > > > > >          return;
> > > > > > > > >      }
> > > > > > > > >
> > > > > > > > > -    ucc = USER_CREATABLE_GET_CLASS(uc);
> > > > > > > > > +    ucc = USER_CREATABLE_GET_CLASS(obj);
> > > > > > > > >      if (ucc->complete) {
> > > > > > > > > -        ucc->complete(uc, errp);
> > > > > > > > > +        ucc->complete(USER_CREATABLE(obj), errp);    
> > > > > > > >                          ^^^
> > > > > > > > even though function becomes more concise,
> > > > > > > > this will call expensive dynamic cast 2nd time 
> > > > > > > > (IS_USER_CREATABLE was the 1st and discarded)
> > > > > > > > so I'm not sure is a good idea to regress startup time for 
> > > > > > > > readability.    
> > > > 
> > > > I hope it's not measurable, unless we create billions of objects. Do
> > > > you want some figures?  
> > > I recall penalty was big enough for QEMU, that we added qom debug option,
> > > in case of -object, the cost could be multiplied by hundreds  
> > 
> > This sounds like premature optimization.  Did you measure how
> > many nanoseconds we're saving per -object option?
> it's not optimization, it's about not making code worse and using
> resources reasonably object_dynamic_cast() with IS_USER_CREATABLE().

How exactly is the code worse?

> 
> I'd replace object_dynamic_cast() with IS_FOO() in places where
> we just test but do not use the result for a better readability.
> But is we need the result later I'd keep object_dynamic_cast(),
> it's not much worse but allows us to reuse the result of cast.

Readability is orders of magnitude more important to me.

This is not readable:
  (UserCreatable *)object_dynamic_cast(obj, TYPE_USER_CREATABLE)

This is readable:
  USER_CREATABLE(obj)

If the overhead of the extra object_dynamic_cast() call is too
much, it's already possible to disable QOM cast debugging.

> [...]

-- 
Eduardo



reply via email to

[Prev in Thread] Current Thread [Next in Thread]