qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v5 1/9] qapi: group BlockDeviceStats fields


From: Vladimir Sementsov-Ogievskiy
Subject: Re: [Qemu-devel] [PATCH v5 1/9] qapi: group BlockDeviceStats fields
Date: Fri, 23 Nov 2018 17:18:03 +0000

31.10.2018 14:34, Anton Nefedov wrote:
> Make the stat fields definition slightly more readable.
> Also reorder total_time_ns stats read-write-flush as done elsewhere.
> Cosmetic change only.
> 
> Signed-off-by: Anton Nefedov <address@hidden>

Reviewed-by: Vladimir Sementsov-Ogievskiy <address@hidden>

> ---
>   qapi/block-core.json | 26 +++++++++++++++-----------
>   1 file changed, 15 insertions(+), 11 deletions(-)
> 
> diff --git a/qapi/block-core.json b/qapi/block-core.json
> index 0fc1590c1b..2903b8dfc9 100644
> --- a/qapi/block-core.json
> +++ b/qapi/block-core.json
> @@ -784,12 +784,12 @@
>   # @flush_operations: The number of cache flush operations performed by the
>   #                    device (since 0.15.0)
>   #
> -# @flush_total_time_ns: Total time spend on cache flushes in nano-seconds
> -#                       (since 0.15.0).
> +# @rd_total_time_ns: Total time spent on reads in nanoseconds (since 0.15.0).
>   #
> -# @wr_total_time_ns: Total time spend on writes in nano-seconds (since 
> 0.15.0).
> +# @wr_total_time_ns: Total time spent on writes in nanoseconds (since 
> 0.15.0).
>   #
> -# @rd_total_time_ns: Total_time_spend on reads in nano-seconds (since 
> 0.15.0).
> +# @flush_total_time_ns: Total time spent on cache flushes in nanoseconds
> +#                       (since 0.15.0).
>   #
>   # @wr_highest_offset: The offset after the greatest byte written to the
>   #                     device.  The intended use of this information is for
> @@ -842,14 +842,18 @@
>   # Since: 0.14.0
>   ##
>   { 'struct': 'BlockDeviceStats',
> -  'data': {'rd_bytes': 'int', 'wr_bytes': 'int', 'rd_operations': 'int',
> -           'wr_operations': 'int', 'flush_operations': 'int',
> -           'flush_total_time_ns': 'int', 'wr_total_time_ns': 'int',
> -           'rd_total_time_ns': 'int', 'wr_highest_offset': 'int',
> -           'rd_merged': 'int', 'wr_merged': 'int', '*idle_time_ns': 'int',
> +  'data': {'rd_bytes': 'int', 'wr_bytes': 'int',
> +           'rd_operations': 'int', 'wr_operations': 'int',
> +           'flush_operations': 'int',
> +           'rd_total_time_ns': 'int', 'wr_total_time_ns': 'int',
> +           'flush_total_time_ns': 'int',
> +           'wr_highest_offset': 'int',
> +           'rd_merged': 'int', 'wr_merged': 'int',
> +           '*idle_time_ns': 'int',
>              'failed_rd_operations': 'int', 'failed_wr_operations': 'int',
> -           'failed_flush_operations': 'int', 'invalid_rd_operations': 'int',
> -           'invalid_wr_operations': 'int', 'invalid_flush_operations': 'int',
> +           'failed_flush_operations': 'int',
> +           'invalid_rd_operations': 'int', 'invalid_wr_operations': 'int',
> +           'invalid_flush_operations': 'int',
>              'account_invalid': 'bool', 'account_failed': 'bool',
>              'timed_stats': ['BlockDeviceTimedStats'],
>              '*x_rd_latency_histogram': 'BlockLatencyHistogramInfo',
> 


-- 
Best regards,
Vladimir

reply via email to

[Prev in Thread] Current Thread [Next in Thread]