[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [Qemu-arm] [PATCH for-4.0 0/2] Rename cpu_physical_memo

From: Peter Maydell
Subject: Re: [Qemu-devel] [Qemu-arm] [PATCH for-4.0 0/2] Rename cpu_physical_memory_write_rom() to address_space_write_rom()
Date: Fri, 14 Dec 2018 11:32:02 +0000

On Thu, 22 Nov 2018 at 13:35, Peter Maydell <address@hidden> wrote:
> The API of cpu_physical_memory_write_rom() is odd, because it
> takes an AddressSpace, unlike all the other cpu_physical_memory_*
> access functions. We note this oddity as a TODO in the
> docs/devel/loads-stores.rst documentation.
> Rename cpu_physical_memory_write_rom() to address_space_write_rom(),
> and give it an API that matches address_space_write().
> We also adjest the cpu_physical_memory_write_rom_internal()
> function which is local to exec.c similarly.

Unless somebody would prefer a different route, I'm going
to add this series to a 'misc' pullreq I'm putting together.

-- PMM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]