[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [Bug 1511887] Re: USB device 1.1 not correctly passedthru f

From: Johansen
Subject: [Qemu-devel] [Bug 1511887] Re: USB device 1.1 not correctly passedthru from Linux host to Windows guest
Date: Tue, 18 Dec 2018 07:23:08 -0000

** Also affects: wine1.6 (Ubuntu)
   Importance: Undecided
       Status: New

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  USB device 1.1 not correctly passedthru from Linux host to Windows

Status in QEMU:
Status in wine1.6 package in Ubuntu:

Bug description:
  I have USB Digital Oscilloscope which works great on pure Windows
  machine but not work on virtualized one. I tried passthru the device
  from my Debian Jessie (64bit) host machine to Windows 7 (32bit) guest
  machine but unfortunately it does not work very well. It looks that
  device is passed thru so Windows machine knows about new device and
  loads HID device driver for it but the device driver failed to start
  the device and details of an error provided by device manager is "This
  device cannot start" Code 10.

  Installed Qemu version: 2.1+dfsg-12+deb8u4 0

  USB device spec: Dynon Instruments ELAB-080, USB 1.1

  On linux host computer
  lsusb identify it as:
  Bus 003 Device 009: ID 13a3:0001 

  lsusb -t identify it as:
  /: Bus 03.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
      |__ Port 1: Dev 9, If 0, Class=Human Interface Device, Driver=usbhid, 12M

  This is how I started my Windows guest machine
  kvm -cpu host \
      -m 2048MiB \
      -hda test.vdi \
      -ctrl-grab \
      -parallel /dev/parport0 \
      -usbdevice host:13a3:0001

  ...also instead of last line I tried this one:
      -device usb-host,vendorid=0x13a3,productid=0x0001

  none of them help to properly handle my device inside guest machine.

  Only one time the Windows guest machine properly start the device so
  software for that oscilloscope can identify the Oscilloscope and
  measure for a while but unfortunately after I guess 5 seconds of
  measurement the device was disconnected from Windows and never start
  working again even after couple of restarts of guest machine even
  after plug and unplug it's USB cable and power cable.

  I searched for a solution or some clues to get it work but none of my
  searching over the internet was successful. Because device works on
  pure Windows but not work on virtualized one, I think there is a
  problem with handling not standard USB devices (like sticks,
  keyboards, mouses etc.)

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]