[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [Bug 1738283] Re: 'Less than' (<), 'more than' (>), and 'pi

From: Adam Williamson
Subject: [Qemu-devel] [Bug 1738283] Re: 'Less than' (<), 'more than' (>), and 'pipe' (|) can't be typed via VNC
Date: Tue, 18 Dec 2018 18:34:07 -0000

Indeed the bug does not exist in this exact form any more, but it seems
the stray '86' keymap entry *does* still cause problems in current qemu
in one specific case:


basically, if using 'usb-kbd', we still get trouble when openQA (os-
autoinst) tries to type a '<' character, because it does this:

shift down
comma down
shift up
comma up

(note it does *not* do shift down, comma down, comma up, shift up), and
qemu gets confused and converts that into this sequence of
input_event_key_qcode events:

shift down
comma down
shift up
less up

and that seems to mess with the key state and cause any subsequent
attempts to type a '<' to go wrong.

Removing the '86' key definition avoids the bug.

** Bug watch added: Red Hat Bugzilla #1658676

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  'Less than' (<), 'more than' (>), and 'pipe' (|) can't be typed via

Status in QEMU:
  Fix Released

Bug description:
  If I start QEMU 2.11 (from
  https://build.opensuse.org/package/show/Virtualization/qemu) VM with
  VNC, I am unable to type following three characters: 'less than' (<),
  'more than' (>), and 'pipe' (|) on en_US QWERTY keyboard. Other
  characters work fine. QEMu version 2.10.1 worked fine.

  /usr/bin/qemu-kvm -m 2048 -cpu kvm64 -drive
  minimal-20171031.iso -device ide-cd,drive=cd0 -boot once=d,menu=on
  ,splash-time=5000 -device usb-ehci -device usb-tablet -smp 1 -enable-
  kvm -vnc :91,share=force-shared

  The ISO can be downloaded here: https://www.openindiana.org/download/

  Also tried Fedora-Server-dvd-x86_64-25-1.3.iso and it's the same

  If I run the same command without '-vnc :91,share=force-shared',
  everything works just fine.

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]