[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [PATCH] hw/i386/pc.c: fix one typo in function name
From: |
Laurent Vivier |
Subject: |
Re: [Qemu-devel] [PATCH] hw/i386/pc.c: fix one typo in function name |
Date: |
Thu, 24 Jan 2019 11:28:13 +0100 |
User-agent: |
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.8.0 |
On 24/01/2019 08:36, Wei Yang wrote:
> Rename pc_get_hotpug_handler to pc_get_hotplug_handler.
>
> No functional change.
>
> Signed-off-by: Wei Yang <address@hidden>
> ---
> hw/i386/pc.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/hw/i386/pc.c b/hw/i386/pc.c
> index 115bc2825c..5317e08f60 100644
> --- a/hw/i386/pc.c
> +++ b/hw/i386/pc.c
> @@ -2059,7 +2059,7 @@ static void pc_machine_device_unplug_cb(HotplugHandler
> *hotplug_dev,
> }
> }
>
> -static HotplugHandler *pc_get_hotpug_handler(MachineState *machine,
> +static HotplugHandler *pc_get_hotplug_handler(MachineState *machine,
> DeviceState *dev)
> {
> if (object_dynamic_cast(OBJECT(dev), TYPE_PC_DIMM) ||
> @@ -2389,7 +2389,7 @@ static void pc_machine_class_init(ObjectClass *oc, void
> *data)
> pcmc->save_tsc_khz = true;
> pcmc->linuxboot_dma_enabled = true;
> assert(!mc->get_hotplug_handler);
> - mc->get_hotplug_handler = pc_get_hotpug_handler;
> + mc->get_hotplug_handler = pc_get_hotplug_handler;
> mc->cpu_index_to_instance_props = pc_cpu_index_to_props;
> mc->get_default_cpu_node_id = pc_get_default_cpu_node_id;
> mc->possible_cpu_arch_ids = pc_possible_cpu_arch_ids;
>
Applied to my trivial-patches branch.
Thanks,
Laurent