[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [Issues] PCI hotplug does not work well on pc platform?

From: Igor Mammedov
Subject: Re: [Qemu-devel] [Issues] PCI hotplug does not work well on pc platform?
Date: Tue, 5 Feb 2019 16:47:16 +0100

On Wed, 30 Jan 2019 21:02:10 +0800
"Liu, Jing2" <address@hidden> wrote:

> Hi everyone,
> I have two questions.
> 1. PCI hotplug on pci.0 must manually rescan in guest. The ACPI hotplug 
> handler sends the GPE event to guest but it seems guest doesn't receive 
> it? I tried to open ACPI debug level/layer to 0xffffffff, in order to 
> see if there is any message after device_add in monitor, but no message 
> comes out until I manually rescan. Also tried printk in 
> acpi_ev_gpe_xrupt_handler() and acpi_ev_sci_xrupt_handler(). No output 
> in dmesg.
> Whether this is a kind of design or a known issue? Does guest receive 
> the request, where can I find the
does it work with known to work kernels (RHEL7)?

Also sharing used QEMU version and command line could help.

> 2. I want to try hotplugging on pci-bridge on pc platform, using shpc. I 
> set shpc=on, but when I do device_add, qemu still calls 
> acpi_pcihp_device_plug_cb? Why it does not call pci_bridge_dev_hotplug_cb?

try to disable ACPI hotplug for bridges
 -global PIIX4_PM.acpi-pci-hotplug-with-bridge-support=off

> Thanks very much!
> Jing

reply via email to

[Prev in Thread] Current Thread [Next in Thread]