[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] sparc: crash when using initrd > 5M

From: Mark Cave-Ayland
Subject: Re: [Qemu-devel] sparc: crash when using initrd > 5M
Date: Fri, 8 Feb 2019 16:09:52 +0000
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.4.0

On 06/02/2019 19:38, Corentin Labbe wrote:

> On Wed, Feb 06, 2019 at 07:37:29AM +0000, Mark Cave-Ayland wrote:
>> On 06/02/2019 07:28, Corentin Labbe wrote:
>>>>> Hello
>>>>> Sorry even with the patch I still hit the issue.
>>>>> I have added some debug and at least qemu set initrd_size correctly now.
>>>>> I have tried to compile openbios-sparc32 for debugging but fail with
>>>>> arch/sparc32/context.c:116:5: error: PIC register clobbered by 'l7' in 
>>>>> 'asm'
>>>>>      asm __volatile__ ("\n\tcall __switch_context"
>>>>>      ^~~
>>>>> make[1]: *** [rules.mak:219: target/arch/sparc32/context.o] Error 1
>>>>> (gcc 7.2 and gc 6.4 with binutils 2.30)
>>>> Hmmm. One other thing I've noticed is that newer kernels tend need a 
>>>> minimum of 256M
>>>> RAM to start up - does it work if you add -m 256 to your command line?
>>> I have already set 256M of RAM. (and tried 512)
>> I wonder then if this is being triggered by a recent kernel change? I tend 
>> to test
>> using the latest Debian ports ISOs which are currently running 4.9 and that 
>> booted
>> fine when I was testing the patches above.
>> Can you try with a few older kernels to see if this is the case?
> Hello
> In fact the problem was due to .config since a defconfig works fine on 
> next-20190205
> After lots of diff I found that CONFIG_LOG_BUF_SHIFT=18 cause this behaviour.
> Note that values of 16,17 cause also the same problem.

Okay, thanks for the feedback. I will aim to merge the OpenBIOS/QEMU patches 
the upcoming QEMU 4.0 release since even if it happens to work now, not passing 
memory allocations/translations via the DT seems a little fragile.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]