qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 1/4] migration/savevm: remove duplicate check of


From: Daniel Henrique Barboza
Subject: Re: [Qemu-devel] [PATCH 1/4] migration/savevm: remove duplicate check of migration_is_blocked
Date: Thu, 25 Apr 2019 16:20:57 -0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.6.1



On 4/23/19 9:46 PM, Wei Yang wrote:
Current call flow of save_snapshot is:

   save_snapshot
     migration_is_blocked
       qemu_savevm_state
         migration_is_blocked

Since qemu_savevm_state is only called in save_snapshot, this means
migration_is_blocked has been already checked.

I think it would be a nice touch to add a comment in qemu_savevm_state,
saying that the function must be called with migration_is_blocked()
context. Just in case someone else in the future ends up re-using the
function.


Other than that, +1 for less code duplication.


Reviewed-by: Daniel Henrique Barboza <address@hidden>





Signed-off-by: Wei Yang <address@hidden>
---
  migration/savevm.c | 4 ----
  1 file changed, 4 deletions(-)

diff --git a/migration/savevm.c b/migration/savevm.c
index 92af2471cd..2eea604624 100644
--- a/migration/savevm.c
+++ b/migration/savevm.c
@@ -1412,10 +1412,6 @@ static int qemu_savevm_state(QEMUFile *f, Error **errp)
          return -EINVAL;
      }
- if (migration_is_blocked(errp)) {
-        return -EINVAL;
-    }
-
      if (migrate_use_block()) {
          error_setg(errp, "Block migration and snapshots are incompatible");
          return -EINVAL;




reply via email to

[Prev in Thread] Current Thread [Next in Thread]