qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] virtio-9p-device: fix memleak in virtio_9p_device_unrealize


From: Christian Schoenebeck
Subject: Re: [PATCH] virtio-9p-device: fix memleak in virtio_9p_device_unrealize
Date: Wed, 15 Jan 2020 12:40:24 +0100

On Mittwoch, 15. Januar 2020 02:28:03 CET Pan Nengyuan wrote:
> >>> diff --git a/hw/9pfs/virtio-9p-device.c b/hw/9pfs/virtio-9p-device.c
> >>> index b5a7c03f26..b146387ae2 100644
> >>> --- a/hw/9pfs/virtio-9p-device.c
> >>> +++ b/hw/9pfs/virtio-9p-device.c
> >>> @@ -215,6 +215,7 @@ static void virtio_9p_device_unrealize(DeviceState
> >>> *dev, Error **errp) V9fsVirtioState *v = VIRTIO_9P(dev);
> >>> 
> >>>      V9fsState *s = &v->state;
> >>> 
> >>> +    virtio_delete_queue(v->vq);
> >>> 
> >>>      virtio_cleanup(vdev);
> >>>      v9fs_device_unrealize_common(s, errp);
> >>>  
> >>>  }
> >> 
> >> Looks like you are using an old interface. The new one is
> >> 
> >>    void virtio_del_queue(VirtIODevice *vdev, int n);
> > 
> > Ah, my bad, it is actually the other way around, that is I was not up to
> > date; virtio_delete_queue() was apparently introduced a week ago:
> > https://lists.gnu.org/archive/html/qemu-devel/2020-01/msg00723.html
> > 
> > The old virtio_del_queue() still exists though:
> > https://github.com/qemu/qemu/blob/master/hw/virtio/virtio.c#L2339
> > 
> > Having said that, it would probably still make sense to use
> > virtio_del_queue() instead for now to make it easier for stable branches
> > to merge this fix?
> virtio_delete_queue makes the cleanup more clear and it tends to replace the
> old one gradually. So I think it would probably still use
> virtio_delete_queue.
> 
> Given that, maybe we can split this patch?
> For example:
> 1. use virtio_del_queue to fix memleak, it's easier for stable to merge.
> 2. rename virtio_del_queue to virtio_delete_queue

Exactly what I had in mind. :) Thanks!

Best regards,
Christian Schoenebeck





reply via email to

[Prev in Thread] Current Thread [Next in Thread]