[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug 1657538] Re: qemu 2.7.x 2.8 softmmu dont work on BE machine

From: Thomas Huth
Subject: [Bug 1657538] Re: qemu 2.7.x 2.8 softmmu dont work on BE machine
Date: Tue, 11 Feb 2020 14:11:48 -0000

Looking through old bug tickets ... can you still reproduce the issue
with the latest version of QEMU (v4.2) and a more recent Linux

** Changed in: qemu
       Status: New => Incomplete

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  qemu 2.7.x 2.8 softmmu dont work on BE machine

Status in QEMU:

Bug description:
  Build on Be machine qemu 2.7.1 and 2.8 in pure softmmu (tgc) dont work on big 
endian hardware .
  tested with ppc-softmmu,i386-softmmu,arm-softmmu same result:

  with :
  Gtk-Message: Failed to load module "overlay-scrollbar"
  qemu-system-i386: Trying to execute code outside RAM or ROM at 0x000a0000
  This usually means one of the following happened:

  (1) You told QEMU to execute a kernel for the wrong machine type, and it 
crashed on startup (eg trying to run a raspberry pi kernel on a versatilepb 
QEMU machine)
  (2) You didn't give QEMU a kernel or BIOS filename at all, and QEMU executed 
a ROM full of no-op instructions until it fell off the end
  (3) Your guest kernel has a bug and crashed by jumping off into nowhere

  This is almost always one of the first two, so check your command line and 
that you are using the right type of kernel for this machine.
  If you think option (3) is likely then you can try debugging your guest with 
the -d debug options; in particular -d guest_errors will cause the log to 
include a dump of the guest register state at this point.

  Execution cannot continue; stopping here.

  I try to add the -L option with ../pc-bios/bios.bin 
  and have the same result.

  note the ppc-softmmu and ppc64-softmmu work in kvm mode only emulated
  mode have issue.

  tested on my hardware a  Qriq P5040 and G5 4x970MP with Ubuntu Mate 16.10 

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]