qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH v2 0/2] Fix MAP_SYNC support when host has older glibc version


From: Eduardo Habkost
Subject: [PATCH v2 0/2] Fix MAP_SYNC support when host has older glibc version
Date: Wed, 11 Mar 2020 19:23:40 -0400

Changes v1 -> v2:
* Use -isystem for $PWD/linux-headers too
  Reported-by: "Michael S. Tsirkin" <address@hidden>

This is an alternative to the patch submitted at:

  From: Jingqi Liu <address@hidden>
  Subject: [PATCH] util: fix to get configuration macros in util/mmap-alloc.c
  Date: Thu,  5 Mar 2020 23:41:42 +0800
  Message-Id: <address@hidden>

Before moving the osdep.h include to the top of the file, we had
to address warnings triggered when <linux/mman.h> was included
after <sys/mman.h> (done in patch 1/2).

Eduardo Habkost (2):
  Use -isystem for linux-headers dir
  mmap-alloc: Include osdep.h before checking CONFIG_LINUX

 Makefile.target   | 2 +-
 configure         | 2 +-
 util/mmap-alloc.c | 7 +++----
 3 files changed, 5 insertions(+), 6 deletions(-)

-- 
2.24.1





reply via email to

[Prev in Thread] Current Thread [Next in Thread]