[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v3 15/16] hw/i386/vmport: Add support for CMD_GETHZ

From: Liran Alon
Subject: Re: [PATCH v3 15/16] hw/i386/vmport: Add support for CMD_GETHZ
Date: Sat, 14 Mar 2020 00:44:55 +0200
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:68.0) Gecko/20100101 Thunderbird/68.5.0

On 13/03/2020 22:07, Philippe Mathieu-Daudé wrote:
On 3/12/20 5:54 PM, Liran Alon wrote:

diff --git a/include/hw/i386/vmport.h b/include/hw/i386/vmport.h
index 34cc050b1ffa..aee809521aa0 100644
--- a/include/hw/i386/vmport.h
+++ b/include/hw/i386/vmport.h
@@ -12,6 +12,7 @@ typedef enum {
+    VMPORT_CMD_GETHZ            = 45,

Can you rename to something easier to read, such _GET_FREQS_HZ or nicer?

I actually prefer to stick with names similar to open-vm-tools. i.e. Similar to the definitions in lib/include/backdoor_def.h. This helps correlates a command in QEMU code to guest code (in open-vm-tools) that interacts with it. I can rename to just VMPORT_CMD_GET_HZ (Similar to what you suggested for previous commands). But I don't have a strong opinion on this. If you still think _GET_FREQ_HZ is preferred, I will rename to that.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]