[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v3 01/19] target/arm: Rename KVM set_feature() as kvm_set_fea

From: Philippe Mathieu-Daudé
Subject: Re: [PATCH v3 01/19] target/arm: Rename KVM set_feature() as kvm_set_feature()
Date: Tue, 17 Mar 2020 10:09:55 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.5.0

On 3/16/20 9:16 PM, Richard Henderson wrote:
On 3/16/20 9:06 AM, Philippe Mathieu-Daudé wrote:
+++ b/target/arm/kvm32.c
@@ -22,7 +22,7 @@
  #include "internals.h"
  #include "qemu/log.h"
-static inline void set_feature(uint64_t *features, int feature)
+static inline void kvm_set_feature(uint64_t *features, int feature)

Why, what's wrong with the existing name?
Plus, with patch 2, you can just remove these.

The prototypes are different:

  void set_feature(uint64_t *features, int feature)

  void set_feature(CPUARMState *env, int feature)

Anyway you are right, I'll use the later prototype instead, thanks.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]