[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v9 05/14] iotests: add pylintrc file

From: John Snow
Subject: Re: [PATCH v9 05/14] iotests: add pylintrc file
Date: Mon, 30 Mar 2020 14:10:08 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.5.0

On 3/30/20 11:49 AM, Kevin Wolf wrote:
> Am 25.03.2020 um 00:20 hat John Snow geschrieben:
>> This allows others to get repeatable results with pylint. If you run
>> `pylint iotests.py`, you should see a 100% pass.
>> Signed-off-by: John Snow <address@hidden>
>> Reviewed-by: Max Reitz <address@hidden>
> I see you said "should" and not "will", but I still get two warnings:
> iotests.py:405:22: W0613: Unused argument 'signum' (unused-argument)
> iotests.py:405:30: W0613: Unused argument 'frame' (unused-argument)
> Kevin

I wasn't entirely sure if it'd work across all versions of pylint, all
versions of python, or what the tree would look like by the time the
patches got applied ... and I didn't see these warnings.

I rebased to origin/master today and with these first five patches applied:

jsnow@probe ~/s/q/w/t/qemu-iotests (iotests-logging)> pylint iotests.py

Your code has been rated at 10.00/10 (previous run: 10.00/10, +0.00)

jsnow@probe ~/s/q/w/t/qemu-iotests (iotests-logging)> pylint --version
pylint 2.3.1
astroid 2.2.5
Python 3.7.6 (default, Jan 30 2020, 10:29:04)
[GCC 9.2.1 20190827 (Red Hat 9.2.1-1)]

I upgraded to pylint 2.4.4 and that seems to work OK too.

So let's try this:

> sudo dnf install python36
> pipenv --python 3.6
> pipenv shell

> pipenv install pylint
> which pylint

(qemu-iotests) jsnow@probe ~/s/q/w/t/qemu-iotests (iotests-logging)>
which pylint

(qemu-iotests) jsnow@probe ~/s/q/w/t/qemu-iotests (iotests-logging)>
pylint --version
pylint 2.4.4
astroid 2.3.3
Python 3.6.10 (default, Dec 27 2019, 13:40:13)
[GCC 9.2.1 20190827 (Red Hat 9.2.1-1)]

Python 3.6:
- Pylint 2.0.0 WARN
- Pylint 2.1.0 WARN
- Pylint 2.2.0 OK
- Pylint 2.4.4 OK
- Pylint 2.3.0 OK

Hm. Python 3.6 is from December 23, 2016 -- but Pylint from that era is
probably Pylint 1.6.5 from Jan 22, 2017.

That's probably ... obnoxiously old to support. Do we have any
viewpoints on minimum version requirements for CQA tools? Modern pylint
works just fine for Python 3.6, but I have no earthly idea if there are
reasons that "old" distributions with Python 3.6 can't get "modern"
pylint packages.

Gut feeling: Any Python 3.6 distribution has pip, and pip can get the
latest packages. It would be OK to require pylint >= 2.2.0, probably.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]