qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH 44/63] renesas: Rename RCMT to RENESAS_CMT


From: Eduardo Habkost
Subject: [PATCH 44/63] renesas: Rename RCMT to RENESAS_CMT
Date: Wed, 2 Sep 2020 18:42:52 -0400

This will make the type name constant consistent with the name of
the type checking macro.

Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
---
Cc: Yoshinori Sato <ysato@users.sourceforge.jp>
Cc: Magnus Damm <magnus.damm@gmail.com>
Cc: qemu-devel@nongnu.org
---
 include/hw/timer/renesas_cmt.h | 2 +-
 hw/timer/renesas_cmt.c         | 4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/include/hw/timer/renesas_cmt.h b/include/hw/timer/renesas_cmt.h
index 1c0b65c1d5..89e83df374 100644
--- a/include/hw/timer/renesas_cmt.h
+++ b/include/hw/timer/renesas_cmt.h
@@ -15,7 +15,7 @@
 
 #define TYPE_RENESAS_CMT "renesas-cmt"
 typedef struct RCMTState RCMTState;
-DECLARE_INSTANCE_CHECKER(RCMTState, RCMT,
+DECLARE_INSTANCE_CHECKER(RCMTState, RENESAS_CMT,
                          TYPE_RENESAS_CMT)
 
 enum {
diff --git a/hw/timer/renesas_cmt.c b/hw/timer/renesas_cmt.c
index 2e0fd21a36..5700980057 100644
--- a/hw/timer/renesas_cmt.c
+++ b/hw/timer/renesas_cmt.c
@@ -214,7 +214,7 @@ static void timer_event1(void *opaque)
 
 static void rcmt_reset(DeviceState *dev)
 {
-    RCMTState *cmt = RCMT(dev);
+    RCMTState *cmt = RENESAS_CMT(dev);
     cmt->cmstr = 0;
     cmt->cmcr[0] = cmt->cmcr[1] = 0;
     cmt->cmcnt[0] = cmt->cmcnt[1] = 0;
@@ -224,7 +224,7 @@ static void rcmt_reset(DeviceState *dev)
 static void rcmt_init(Object *obj)
 {
     SysBusDevice *d = SYS_BUS_DEVICE(obj);
-    RCMTState *cmt = RCMT(obj);
+    RCMTState *cmt = RENESAS_CMT(obj);
     int i;
 
     memory_region_init_io(&cmt->memory, OBJECT(cmt), &cmt_ops,
-- 
2.26.2




reply via email to

[Prev in Thread] Current Thread [Next in Thread]