[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH 0/8] qom: Rename macros for consistency (pass 2)

From: Eduardo Habkost
Subject: [PATCH 0/8] qom: Rename macros for consistency (pass 2)
Date: Thu, 3 Sep 2020 14:01:20 -0400

Reducing boilerplate QOM code using the new OBJECT_DEFINE_* and
OBJECT_DECLARE_* macros is quite difficult when there are
multiple ways a TYPE_* constant name is written.

This series renames many type checking macros and/or TYPE_*
constants to make sure they are consistent.

This is a second pass of cleanups, incorporating suggestions
Philippe and Daniel sent when reviewing the previous series[1].

This series is based on machine-next and can be fetched from:

  https://github.com/ehabkost/qemu-hacks work/qom-rename-macros-pass2


Eduardo Habkost (8):
  i8254: Rename TYPE_I8254 to TYPE_ISA_PIT
  i8254: Rename PIT to ISA_PIT
  i8259: Rename TYPE_I8259 to TYPE_ISA_I8259
  i8259: Rename PIC to ISA_I8259
  i8259: Rename KVM_PIC to KVM_I8259
  esp-pci: Rename TYPE_AM53C974_DEVICE to TYPE_AM53C974
  esp-pci: Rename PCI_ESP to AM53C974
  tusb6010: Rename TUSB to TUSB6010

 include/hw/timer/i8254.h |  4 ++--
 hw/i386/kvm/i8259.c      |  6 +++---
 hw/intc/i8259.c          | 16 ++++++++--------
 hw/scsi/esp-pci.c        | 16 ++++++++--------
 hw/timer/i8254.c         | 10 +++++-----
 hw/usb/tusb6010.c        |  6 +++---
 6 files changed, 29 insertions(+), 29 deletions(-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]