[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug 1894869] Re: Chelsio T4 has old MSIX PBA offset bug

From: Nick Bauer
Subject: [Bug 1894869] Re: Chelsio T4 has old MSIX PBA offset bug
Date: Tue, 15 Sep 2020 06:15:06 -0000

Yeah, I figured out that the logic behind that patch was failed and
corrected it to get the same error again already. Just to clarify, it is
two of the same card giving the same error. I ran dmesg --level=err, but
got no output. In the full output of dmesg, though, I noticed that there
are some problems with the nics, but I don't know enough about this to
know if there's anything I can do about it. I included dmesg output
here. I don't believe the nics are giving the host any functionality
since I added the driver for them to the blacklist, so it shouldn't even
be getting loaded by it. In case it's useful, I'm not sure if SR-IOV is
enabled on these cards or not, though I'm trying to use PCI passthrough
for my VMs.

** Attachment added: "Output of dmesg"

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  Chelsio T4 has old MSIX PBA offset bug

Status in QEMU:
Status in Debian:
  In Progress

Bug description:
  There exists a bug with Chelsio NICs T4 that causes the following

  kvm: -device vfio-
  pci,host=0000:83:00.7,id=hostpci1.7,bus=pci.0,addr=0x11.7: vfio
  0000:83:00.7: hardware reports invalid configuration, MSIX PBA outside
  of specified BAR

  I discovered this bug on a Proxmox system, and I was working with a
  downstream Proxmox developer to try to fix this issue. They provided
  me with the following change to make from line 1484 of hw/vfio/pci.c:

  static void vfio_msix_early_setup(VFIOPCIDevice *vdev, Error **errp)
            * is 0x1000, so we hard code that here.
           if (vdev->vendor_id == PCI_VENDOR_ID_CHELSIO &&
  -            (vdev->device_id & 0xff00) == 0x5800) {
  +            ((vdev->device_id & 0xff00) == 0x5800 ||
  +             (vdev->device_id & 0xff00) == 0x1425)) {
               msix->pba_offset = 0x1000;
           } else if (vdev->msix_relo == OFF_AUTOPCIBAR_OFF) {
               error_setg(errp, "hardware reports invalid configuration, "

  However, I found that this did not fix the issue, so the bug appears
  to work differently than the one that was present on the T5 NICs which
  has already been patched. I have attached the output of my lspci

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]