[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH v2 0/5] hw: Replace some magic by definitions

From: Philippe Mathieu-Daudé
Subject: [PATCH v2 0/5] hw: Replace some magic by definitions
Date: Mon, 12 Oct 2020 15:20:11 +0200

A bunch of trivial cleanups, replacing magic
values by definitions to make the code easier
to review.

Since v1:
- Addressed Peter review comment on versatile PCI controller
- Added Thomas R-b tag

Expected to be merged via qemu-trivial@.



Philippe Mathieu-Daudé (5):
  hw: Replace magic value by PCI_NUM_PINS definition
  hw/pci-host/pam: Use ARRAY_SIZE() instead of magic value
  hw/pci-host/versatile: Add the MEMORY_WINDOW_COUNT definition
  hw/pci-host/versatile: Add the PCI_BAR_COUNT definition
  tests/qtest: Replace magic value by NANOSECONDS_PER_SECOND definition

 hw/arm/virt.c           |  4 ++--
 hw/mips/gt64xxx_pci.c   |  2 +-
 hw/pci-host/pam.c       |  2 +-
 hw/pci-host/versatile.c | 46 ++++++++++++++++++++++-------------------
 tests/qtest/rtc-test.c  |  2 +-
 5 files changed, 30 insertions(+), 26 deletions(-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]