qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH v2 5/5] tests/qtest: Replace magic value by NANOSECONDS_PER_SECON


From: Philippe Mathieu-Daudé
Subject: [PATCH v2 5/5] tests/qtest: Replace magic value by NANOSECONDS_PER_SECOND definition
Date: Mon, 12 Oct 2020 15:20:16 +0200

Use self-explicit NANOSECONDS_PER_SECOND definition instead
of a magic value.

Reviewed-by: Thomas Huth <thuth@redhat.com>
Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
---
 tests/qtest/rtc-test.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/tests/qtest/rtc-test.c b/tests/qtest/rtc-test.c
index c7af34f6b1b..402ce2c6090 100644
--- a/tests/qtest/rtc-test.c
+++ b/tests/qtest/rtc-test.c
@@ -292,7 +292,7 @@ static void alarm_time(void)
             break;
         }
 
-        clock_step(1000000000);
+        clock_step(NANOSECONDS_PER_SECOND);
     }
 
     g_assert(get_irq(RTC_ISA_IRQ));
-- 
2.26.2




reply via email to

[Prev in Thread] Current Thread [Next in Thread]