[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v2 07/27] failover: qdev_device_add() returns err or dev set
From: |
Juan Quintela |
Subject: |
[PATCH v2 07/27] failover: qdev_device_add() returns err or dev set |
Date: |
Wed, 18 Nov 2020 09:37:28 +0100 |
Never both.
Signed-off-by: Juan Quintela <quintela@redhat.com>
---
hw/net/virtio-net.c | 7 -------
1 file changed, 7 deletions(-)
diff --git a/hw/net/virtio-net.c b/hw/net/virtio-net.c
index 6ca85627d8..3e82108d42 100644
--- a/hw/net/virtio-net.c
+++ b/hw/net/virtio-net.c
@@ -803,13 +803,6 @@ static void failover_add_primary(VirtIONet *n, Error
**errp)
if (err) {
qemu_opts_del(n->primary_device_opts);
}
- if (n->primary_dev) {
- if (err) {
- qdev_unplug(n->primary_dev, &err);
- qdev_set_id(n->primary_dev, "");
-
- }
- }
} else {
error_setg(errp, "Primary device not found");
error_append_hint(errp, "Virtio-net failover will not work. Make "
--
2.26.2
- [PATCH v2 00/27] Virtio net failover fixes, Juan Quintela, 2020/11/18
- [PATCH v2 01/27] migration: Network Failover can't work with a paused guest, Juan Quintela, 2020/11/18
- [PATCH v2 02/27] failover: fix indentantion, Juan Quintela, 2020/11/18
- [PATCH v2 04/27] failover: primary bus is only used once, and where it is set, Juan Quintela, 2020/11/18
- [PATCH v2 03/27] failover: Use always atomics for primary_should_be_hidden, Juan Quintela, 2020/11/18
- [PATCH v2 05/27] failover: Remove unused parameter, Juan Quintela, 2020/11/18
- [PATCH v2 06/27] failover: Remove external partially_hotplugged property, Juan Quintela, 2020/11/18
- [PATCH v2 08/27] failover: Rename bool to failover_primary_hidden, Juan Quintela, 2020/11/18
- [PATCH v2 09/27] failover: g_strcmp0() knows how to handle NULL, Juan Quintela, 2020/11/18
- [PATCH v2 07/27] failover: qdev_device_add() returns err or dev set,
Juan Quintela <=
- [PATCH v2 10/27] failover: Remove primary_device_opts, Juan Quintela, 2020/11/18
- [PATCH v2 11/27] failover: remove standby_id variable, Juan Quintela, 2020/11/18
- [PATCH v2 13/27] failover: Remove memory leak, Juan Quintela, 2020/11/18
- [PATCH v2 12/27] failover: Remove primary_device_dict, Juan Quintela, 2020/11/18
- [PATCH v2 14/27] failover: simplify virtio_net_find_primary(), Juan Quintela, 2020/11/18
- [PATCH v2 15/27] failover: should_be_hidden() should take a bool, Juan Quintela, 2020/11/18
- [PATCH v2 16/27] failover: Rename function to hide_device(), Juan Quintela, 2020/11/18
- [PATCH v2 17/27] failover: virtio_net_connect_failover_devices() does nothing, Juan Quintela, 2020/11/18
- [PATCH v2 18/27] failover: Rename to failover_find_primary_device(), Juan Quintela, 2020/11/18
- [PATCH v2 19/27] failover: simplify qdev_device_add() failover case, Juan Quintela, 2020/11/18